Results 1 to 8 of 8

Thread: Problem with streaming to mobile

  1. #1
    Join Date
    Jan 2013
    Posts
    2

    Default Problem with streaming to mobile

    Hello!
    I have problem with streaming h263 to mobile devices (I tested in example on Nokia 5130 or Nokia N95 or Samsung Monte 5620). On all devices stream failed. I tested it on pc also. VLC works fine, but QuickTime failed. It shows in info h263 Stream, but it has 0fps and size 0x0...
    Here is my template:

    <!-- Example template for transrate, producing four new streams at different bitrates. Resultant streams can be played back individually or as a group. source, 360p and 160p encode blocks are enabled through the Enable property, other examples are not enabled. Add additional encode blocks to your template as needed. -->
    <Root>
    <Transcode>
    <Encodes>
    <!-- Example Encode block for source, not required unless Member of StreamNameGroup. -->
    <Encode>
    <Enable>false</Enable>
    <Name>source</Name>
    <StreamName>mp4:${SourceStreamName}_source</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceVideoBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    <Encode>
    <Enable>true</Enable>
    <Name>720p</Name>
    <StreamName>mp4:${SourceStreamName}_720p</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>1280</Width>
    <Height>720</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>1300000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 360p, high bandwith, main profile for desktop -->
    <Encode>
    <Enable>true</Enable>
    <Name>360p</Name>
    <StreamName>mp4:${SourceStreamName}_360p</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>640</Width>
    <Height>360</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>850000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 240p, medium bandwidth, baseline profile -->
    <Encode>
    <Enable>false</Enable>
    <Name>240p</Name>
    <StreamName>mp4:${SourceStreamName}_240p</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.263</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>360</Width>
    <Height>240</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>350000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    <Encode>
    <Enable>true</Enable>
    <Name>160p</Name>
    <StreamName>mp4:${SourceStreamName}_160p</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.263</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>crop</FitMode>
    <Width><!--284-->176</Width>
    <Height><!--160-->144</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>32000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>80</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>12000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    <!-- Property>
    <Name>sourceStreamFrameRate</Name>
    <Value>15</Value>
    <Type>Double</Type>
    </Property -->
    </Properties>
    </Encode>
    <!-- Setup for H.263, low bandwith, streaming to older mobile devices -->
    <Encode>
    <Enable>true</Enable>
    <Name>h263</Name>
    <StreamName>mp4:${SourceStreamName}_h263</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.263</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>176</Width>
    <Height>144</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>64000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>Disable</Codec>
    <Bitrate>12000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    </Encodes>
    <Decode>
    <Video>
    <Deinterlace>false</Deinterlace>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Properties>
    </Properties>
    </Decode>
    <StreamNameGroups>
    <!-- Note: Play stream using stream name ngrp:[stream-name] -->
    <StreamNameGroup>
    <Name>${SourceStreamName}_all</Name>
    <Members>
    <Member>
    <EncodeName>source</EncodeName>
    </Member>
    <Member>
    <EncodeName>720p</EncodeName>
    </Member>
    <Member>
    <EncodeName>360p</EncodeName>
    </Member>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    <StreamNameGroup>
    <Name>${SourceStreamName}_mobile</Name>
    <Members>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    </StreamNameGroups>
    <Properties>
    </Properties>
    </Transcode>
    </Root>
    and my application.xml:

    <Root>
    <Application>
    <!-- Uncomment to set application level timeout values
    <ApplicationTimeout>60000</ApplicationTimeout>
    <PingTimeout>12000</PingTimeout>
    <ValidationFrequency>8000</ValidationFrequency>
    <MaximumPendingWriteBytes>0</MaximumPendingWriteBytes>
    <MaximumSetBufferTime>60000</MaximumSetBufferTime>
    <MaximumStorageDirDepth>25</MaximumStorageDirDepth>
    -->
    <Connections>
    <AutoAccept>true</AutoAccept>
    <AllowDomains></AllowDomains>
    </Connections>
    <!--
    StorageDir path variables

    ${com.wowza.wms.AppHome} - Application home directory
    ${com.wowza.wms.ConfigHome} - Configuration home directory
    ${com.wowza.wms.context.VHost} - Virtual host name
    ${com.wowza.wms.context.VHostConfigHome} - Virtual host config directory
    ${com.wowza.wms.context.Application} - Application name
    ${com.wowza.wms.context.ApplicationInstance} - Application instance name

    -->
    <Streams>
    <StreamType>live</StreamType>
    <StorageDir>${com.wowza.wms.context.VHostConfigHome}/content</StorageDir>
    <KeyDir>${com.wowza.wms.context.VHostConfigHome}/keys</KeyDir>
    <!-- LiveStreamPacketizers (separate with commas): cupertinostreamingpacketizer, smoothstreamingpacketizer, sanjosestreamingpacketizer, cupertinostreamingrepeater, smoothstreamingrepeater, sanjosestreamingrepeater, dvrstreamingpacketizer, dvrstreamingrepeater -->
    <LiveStreamPacketizers></LiveStreamPacketizers>
    <!-- Properties defined here will override any properties defined in conf/Streams.xml for any streams types loaded by this application -->
    <Properties>
    </Properties>
    </Streams>
    <Transcoder>
    <!-- To turn on transcoder set to: transcoder -->
    <LiveStreamTranscoder>transcoder</LiveStreamTranscoder>
    <!-- [templatename].xml or ${SourceStreamName}.xml -->
    <Templates>${SourceStreamName}.xml,transrate.xml</Templates>
    <ProfileDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/profiles</ProfileDir>
    <TemplateDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/templates</TemplateDir>
    <Properties>
    </Properties>
    </Transcoder>

    <DVR>
    <!-- As a single server or as an origin, use dvrstreamingpacketizer in LiveStreamPacketizers above -->
    <!-- Or, in an origin-edge configuration, edges use dvrstreamingrepeater in LiveStreamPacketizers above -->
    <!-- As an origin, also add dvrchunkstreaming to HTTPStreamers below -->

    <!-- To turn on DVR recording set Recorders to dvrrecorder. This works with dvrstreamingpacketizer -->
    <Recorders></Recorders>

    <!-- As a single server or as an origin, set the Store to dvrfilestorage-->
    <!-- edges should have this empty -->
    <Store></Store>

    <!-- Window Duration is length of live DVR window in seconds. 0 means the window is never trimmed. -->
    <WindowDuration>0</WindowDuration>

    <!-- Storage Directory is top level location where dvr is stored. e.g. c:/temp/dvr -->
    <StorageDir>${com.wowza.wms.context.VHostConfigHome}/dvr</StorageDir>

    <!-- valid ArchiveStrategy values are append, version, delete -->
    <ArchiveStrategy>append</ArchiveStrategy>

    <!-- If this is a dvrstreamingrepeater, define ChunkOriginURL to point back to origin -->
    <!-- And define Application/Repeater/OriginURL to point back to the origin -->
    <Repeater>
    <ChunkOriginURL></ChunkOriginURL>
    </Repeater>

    <!-- Properties for DVR -->
    <Properties>
    </Properties>
    </DVR>

    <!-- HTTPStreamers (separate with commas): cupertinostreaming, smoothstreaming, sanjosestreaming, dvrchunkstreaming -->
    <HTTPStreamers><!--smoothstreaming,cupertinostreaming--><!-- cupertinostreaming,smoothstreaming,sanjosestreaming --></HTTPStreamers>
    <SharedObjects>
    <StorageDir></StorageDir>
    </SharedObjects>
    <Client>
    <IdleFrequency>-1</IdleFrequency>
    <Access>
    <StreamReadAccess>*</StreamReadAccess>
    <StreamWriteAccess>*</StreamWriteAccess>
    <StreamAudioSampleAccess></StreamAudioSampleAccess>
    <StreamVideoSampleAccess></StreamVideoSampleAccess>
    <SharedObjectReadAccess>*</SharedObjectReadAccess>
    <SharedObjectWriteAccess>*</SharedObjectWriteAccess>
    </Access>
    </Client>
    <RTP>
    <!-- RTP/Authentication/[type]Methods defined in Authentication.xml. Default setup includes; none, basic, digest -->
    <Authentication>
    <PublishMethod>digest</PublishMethod>
    <PlayMethod>none</PlayMethod>
    </Authentication>
    <!-- RTP/AVSyncMethod. Valid values are: senderreport, systemclock, rtptimecode -->
    <AVSyncMethod>senderreport</AVSyncMethod>
    <MaxRTCPWaitTime>12000</MaxRTCPWaitTime>
    <IdleFrequency>75</IdleFrequency>
    <RTSPSessionTimeout>90000</RTSPSessionTimeout>
    <RTSPMaximumPendingWriteBytes>0</RTSPMaximumPendingWriteBytes>
    <RTSPBindIpAddress></RTSPBindIpAddress>
    <RTSPConnectionIpAddress>5.133.9.195</RTSPConnectionIpAddress>
    <RTSPOriginIpAddress>5.133.9.195</RTSPOriginIpAddress>
    <IncomingDatagramPortRanges>*</IncomingDatagramPortRanges>
    <!-- Properties defined here will override any properties defined in conf/RTP.xml for any depacketizers loaded by this application -->
    <Properties>
    <Name>videoIsAligned</Name>
    <Value>false</Value>
    <Type>Boolean</Type>
    </Properties>
    </RTP>
    <MediaCaster>
    <RTP>
    <RTSP>
    <!-- udp, interleave -->
    <RTPTransportMode>udp</RTPTransportMode>
    </RTSP>
    </RTP>
    <!-- Properties defined here will override any properties defined in conf/MediaCasters.xml for any MediaCasters loaded by this applications -->
    <Properties>
    </Properties>
    </MediaCaster>
    <MediaReader>
    <!-- Properties defined here will override any properties defined in conf/MediaReaders.xml for any MediaReaders loaded by this applications -->
    <Properties>
    </Properties>
    </MediaReader>
    <MediaWriter>
    <!-- Properties defined here will override any properties defined in conf/MediaWriter.xml for any MediaWriter loaded by this applications -->
    <Properties>
    </Properties>
    </MediaWriter>
    <LiveStreamPacketizer>
    <!-- Properties defined here will override any properties defined in conf/LiveStreamPacketizers.xml for any LiveStreamPacketizers loaded by this applications -->
    <Properties>
    </Properties>
    </LiveStreamPacketizer>
    <HTTPStreamer>
    <!-- Properties defined here will override any properties defined in conf/HTTPStreamers.xml for any HTTPStreamer loaded by this applications -->
    <Properties>
    </Properties>
    </HTTPStreamer>
    <Repeater>
    <OriginURL></OriginURL>
    <QueryString><![CDATA[]]></QueryString>
    </Repeater>
    <Modules>
    <Module>
    <Name>base</Name>
    <Description>Base</Description>
    <Class>com.wowza.wms.module.ModuleCore</Class>
    </Module>
    <Module>
    <Name>properties</Name>
    <Description>Properties</Description>
    <Class>com.wowza.wms.module.ModuleProperties</Class>
    </Module>
    <Module>
    <Name>logging</Name>
    <Description>Client Logging</Description>
    <Class>com.wowza.wms.module.ModuleClientLogging</Class>
    </Module>
    <Module>
    <Name>flvplayback</Name>
    <Description>FLVPlayback</Description>
    <Class>com.wowza.wms.module.ModuleFLVPlayback</Class>
    </Module>
    <Module>
    <Name>reporter</Name>
    <Description>Raporty do playboya</Description>
    <Class>pl.independentdigital.playboy.Reporter</Class>
    </Module>
    <Module>
    <Name>playboyWS</Name>
    <Description>WebService do playboya</Description>
    <Class>pl.independentdigital.playboy.PlayboyWS</Class>
    </Module>
    </Modules>
    <!-- Properties defined here will be added to the IApplication.getProperties() and IApplicationInstance.getProperties() collections -->
    <Properties>
    </Properties>
    </Application>

    </Root>
    i am testing on both h263 and 160p stream..
    no errors in logs..

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I don't have that kind of mobile device, but it also works in my local VLC test.

    The most likely problem is UDP ports. Take a look at these guides:

    http://www.wowza.com/forums/content....-RTP-streaming

    http://www.wowza.com/forums/content....P-RTP-playback

    Richard

  3. #3
    Join Date
    Jan 2013
    Posts
    2

    Default

    hello.
    Thank you Rralnham for reply.
    I've made all changes from both links but still no results. I've also tried to test it on localhost but still the same. Can you do test with quicktime? I think problem is with size 0x0 and 0 fps sent by server. Ah.. and also sometimes there are 4 streams (2 with audio and 2 with video). why is that?

    here is my screen from quicktime:


    and there is no video at all, only audio
    Last edited by ghosts; 01-08-2013 at 04:02 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Re-start Wowza and run through your tests, then zip up and send /conf, /logs and /transcoder folders to support@wowza.com

    Include a link to this thread for reference

    Richard

  5. #5

    Default

    Quote Originally Posted by rrlanham View Post
    Re-start Wowza and run through your tests, then zip up and send /conf, /logs and /transcoder folders to support@wowza.com

    Include a link to this thread for reference

    Richard
    Hello Richard, I have exactly the same problem. Have you please solved the problem?

    THNX

    V.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Can you describe what you are doing and what the problem is, in your case? What source, encoding, device you are streaming to, what kind of stream.

    Richard

  7. #7

    Default

    Quote Originally Posted by rrlanham View Post
    Can you describe what you are doing and what the problem is, in your case? What source, encoding, device you are streaming to, what kind of stream.

    Richard
    FMLE 3.5 H264/AAC to Transcoder/Origin to Edge

    Streaming to Nokia (H263) or VLC (testing)

    I get the same screen as you can see earlier in the thread.

    <!-- 176_144 H.263-->
    <Encode>
    <Enable>true</Enable>
    <Name>176_144</Name>
    <StreamName>mp4:${SourceStreamName}_h263</StreamName>
    <Video>
    <!-- H.264, H.263, PassThru, Disable -->
    <Codec>H.263</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>letterbox</FitMode>
    <Width>176</Width>
    <Height>144</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>90000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <CheckForUpdates>false</CheckForUpdates>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>24000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    In VLC check Tools > Codec info. If there are two audio blocks and two video blocks with duplicate info, that indicates a problem with UDP ports. VLC is failing over to TCP, however many rtsp mobile devices only support UDP.

    Review this guide:
    http://www.wowza.com/forums/content....P-RTP-playback

    I just tested locally, using scheduler to stream sample.mp4 to a application with Transcoder enabled, and the "h263" Encode enabled. I played it back in VLC.

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •