Results 1 to 3 of 3

Thread: Mediacache with Rackspace

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Mediacache with Rackspace

    Dear Forum

    I'm attempting to use the Mediacache plugin with my Rackspace CDN and ran into a few snags after following the documentation.

    The sample file can be seen here:

    http://96817fcbfd0868ea32fb-60d22979...mple_mpeg4.mp4

    When I use the syntax of:

    http://198.101.154.87:1935/mediacach...nst_/mp4:http/96817fcbfd0868ea32fb-60d22979b2bd29c3c8d8934cd8033c71.r57.cf2.rackcdn.com/sample_mpeg4.mp4

    I get the following error:

    WARN server comment 2013-01-23 00:00:04 - - - - - 84000.267 - - - - - - - - NetConnectionConnection.connect: Failed to connect[22cb51aa06764060e4d3-60d22979b2bd29c3c8d8934cd8033c71.r57.stream.cf2.rackcdn.com:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].

    It appears to be trying to access a different location (?). Also, it appears to be trying to connect to port 1935 port on the CDN, is this correct?

    Here are the files that require adjustment, an also here is a sample of the error log:

    Application xml:
    http://pastebin.com/kChp6knr

    Server xml:
    http://pastebin.com/z7PiYjXp

    Mediacache xml:
    http://pastebin.com/PP7LKFbn

    Portion of the error log:
    http://pastebin.com/ah8B1AB9

    Any help would be great! The directions seemed pretty straight forward, so I have no idea what may be causing this.

    Thank you for your support!
    Cheryl
    Last edited by cherylfoster777; 01-23-2013 at 02:45 AM.

  2. #2

    Default

    For some reason this page is adding a space into "8033c71.r57.cf2.rackcdn.com/sample_mpeg4.mp4" above and turning it into "8033c71.r57.cf2.rackcdn.c om/sample_mpeg4.mp4" -

    I don't know why this is, but if you try the address without the space you will see that it does not work.

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The problem is the Server.xml, the MediaCache ServerListener: You have added the <BaseClass> but it needs to be wrapped in <ServerListener></ServerListener> tags. Refer to the commented out ServerListeners above it in your Server.xml file. Fix that, then re-start Wowza and test playback again.

    btw, using MediaCache and playback of cupertino stream would not involve a RTMP Netconnection.

    Richard

Similar Threads

  1. Need help configuring live audio streaming, redundant solution with rackspace / FLME
    By viavid in forum Wowza Streaming Engine functionality
    Replies: 2
    Last Post: 08-19-2014, 12:20 AM
  2. Need immediate load balancing help on Rackspace
    By LBonRackspace in forum Wowza Streaming Engine functionality
    Replies: 3
    Last Post: 08-11-2014, 05:58 AM
  3. Server Architecture on Rackspace
    By McFly76 in forum General Forum
    Replies: 6
    Last Post: 01-25-2013, 01:13 AM
  4. Playing Files from Other Containers (Rackspace CDN)
    By Benny Veo in forum AddOn: Other AddOns
    Replies: 5
    Last Post: 07-09-2012, 02:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •