Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Wrong livestream duration when using transcoder + ngrp

  1. #1
    Join Date
    Jan 2013
    Posts
    17

    Default Wrong livestream duration when using transcoder + ngrp

    Hi!

    We're using Wowza 3.5 + nDVR + transcoder and have had strange problem with playback using OSMF and NGRP-playlist.
    Because of tough conditions while production environment streaming I've had to emulate FMLE disconnection a few times. After emulation OSMF player shows that overall stream session time increased for random value. For example, at the moment of FMLE connection termination it was really 02:15:43 and after reestablishing connection, refreshing page with player and starting playback player shows overall time 11:35:17, plays stream for a few seconds and then go to infinite buffering state.
    Live session URL with ?DVR continue to work and returns real time but not all the times, in some test this combination also was malfincted with similar symptoms.

    DVR strategy is «delete» with timeout = 3 hours, enabled packetizers: SanJose, Cupertino, DVR, stream type — live-lowlatency, live-record, live-record-lowlatency, no difference.

    Thank you in advance.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Are the "tough conditions" limited uplink bandwidth for the Wowza Transcoder? That can cause a lot of problems.

    Richard

  3. #3
    Join Date
    Jan 2013
    Posts
    17

    Default

    Slow or periodically disconnected network connection on the side of Flash Media Encoder, that's why disconnection tests between Wowza and Encoder were made. Wowza used for live events streaming with functionality of DVR and adaptive bitrate.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I think between Transcoding and nDVR, if the source is not stable you are going to have problems that Wowza is not always going to be able to handle.

    Richard

  5. #5
    Join Date
    Jan 2013
    Posts
    17

    Default

    Is the problem with wrong streaming session one of this which couldn'be handled? What you think can be the reason if url without ngrp works well, dvr directory on disk contains files with names equals to real session time but ngrp:live_all URL fails to work correct? Is I'm the only one Wowza user who have periodically lost connection between RTMP source and Wowza Media Server during one streaming event?
    Last edited by maxkachalin; 01-25-2013 at 03:42 PM.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I suggest you take the "tough conditions" factor out for testing and comparison. Test all local if possible

    Richard

  7. #7
    Join Date
    Jan 2013
    Posts
    17

    Default

    All tests were made on server and rtmp source located in one room. Without disconnecting source all works great, before source disconnection tests streaming session lasted for more than a couple of hours without any problem. In the next test I started new translation, emulated disconnection after 10 minutes from the beginning of streaming session, wait for a minute, returned network connection, all worked well, then I tested again and saw that timeline duration in player became 26 minutes instead of 14 in real and http://...application/ngrp:live_all/manifest.f4m?DVR URL stoped to work while http://...application/live/manifest.f4m?DVR continued to work well and player with this source URL showed real duration in timeline.
    Last edited by maxkachalin; 01-25-2013 at 03:56 PM.

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I understand, it is a stress test. I think you will need a stable source to do what you want to do.

    Richard

  9. #9
    Join Date
    Jan 2013
    Posts
    17

    Default

    Ok, I'll try to resolve my question using append or delete with 1 sec timeout DVR strategies. Do you think my problem is related to transcoder or nDVR addon?
    Last edited by maxkachalin; 01-26-2013 at 12:48 AM.

  10. #10
    Join Date
    Jan 2013
    Posts
    17

    Default

    Richard as I've understood you said that Wowza isn't able to handle correctly nDVR+transcoding in unstable network condition between source and media-server? Am i right?
    Last edited by maxkachalin; 01-26-2013 at 12:49 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Using source stream in transcoder ngrp
    By lyinawake in forum AddOn: Transcoder
    Replies: 1
    Last Post: 09-13-2013, 10:25 AM
  2. Mp4 stream recorded with live-record has wrong duration
    By tigicongress in forum General Forum
    Replies: 8
    Last Post: 10-30-2012, 05:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •