Results 1 to 3 of 3

Thread: HTTP stream to Huawei Android Mobile Phone

  1. #1
    Join Date
    Jan 2013
    Posts
    2

    Default HTTP stream to Huawei Android Mobile Phone

    Hi all,

    Having some issues at the moment with HTTP streaming.

    We are using:
    http streaming
    h.264
    mp4
    @ 200kbps

    Which has been encoded by encoding.com It creates 3 formats: 1. Mobile 2. Medium 3. High. The mobile is being streamed to the app. We use the Android Media Player to play the files.

    At the moment, any content which is longer than 20 minutes is stopped on the app. It can vary, so for example for a 30 minute file the video will stop at 17 minutes, or 18 minutes. There has been no mathmatical pattern across various videos. However, it is never in the first 1-10 minutes in the video.

    We have a Dashboard, where we can Preview the medium and high version, not the mobile. We are only going by these versions that the mobile has encoded successfully and Encoding.com's Finished notification.

    Here is a note from our app team:

    Wowza/Encoding
    I have tried setting different encoding settings in encoding.com to only
    slight improvements and with Wowza I have tried different configuration
    settings on their server for the wowza app that streams the content, to
    help audio/video lag and dropped frames but again to no avail.

    For Wowza/Encoding – mobile settings

    Mobile **/
    $formatNode = $req->addChild(‘format’);

    $formatNode->addChild(‘destination’,
    $sftpDir.$uniqueMediaIdentifier.’_mobile.mp4’);
    $formatNode->addChild(‘output’, ‘mp4’);

    //Audio
    $formatNode->addChild(‘audio_bitrate’,
    ‘56k’);
    //$formatNode->addChild(‘audio_sample_rate’,
    ‘22050’);
    $formatNode->addChild(‘audio_channels_number’,
    ‘1’);
    $formatNode->addChild(‘audio_codec’,
    ‘libfaac’);

    //Video
    $formatNode->addChild(‘bitrate’, ‘200k’);
    $formatNode->addChild(‘cbr’, ‘yes’);
    $formatNode->addChild(‘keep_aspect_ratio’,
    ‘yes’);
    $formatNode->addChild(‘video_codec’,
    ‘libx264’);
    $formatNode->addChild(‘profile’, ‘baseline’);
    $formatNode->addChild(‘size’, ‘0x160’);



    Thanks guys
    Last edited by adamb1026; 01-28-2013 at 08:51 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    We recommend RTSP streaming to Android because of these kind of reports. Have you tested these streams in RTMP or other clients? Is there any similar behavior?

    Have you tried the Wowza Transcoder?
    http://www.wowza.com/forums/content....live-streaming

    Richard

  3. #3
    Join Date
    Jan 2013
    Posts
    2

    Default

    Hi Richard,

    We are currently using http streaming for On Device viewing. We were originally using RTSP, but this produce ghosting and audio, video lag.

    We are not live streaming, this is for on demand content already encoded, so we used encoding.com rather than the Wowza Transcoder.

    Thanks.

Similar Threads

  1. Can I stream from Windows 8 Phone or Android Phones?
    By rotorboy in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 06-06-2014, 05:33 PM
  2. android 4.2 mobile-phone + moboplayer error message
    By solaris32 in forum General Forum
    Replies: 3
    Last Post: 05-31-2013, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •