Results 1 to 3 of 3

Thread: httpProvider and POST method

  1. #1

    Unhappy httpProvider and POST method

    Hello, I need to send POST request to the wowza. But when I am doing it with php CURL:

    PHP Code:
        $url "http://127.0.0.1:1935/myapp";

        
    $ch curl_init();
        
    curl_setopt($chCURLOPT_URL$url);
        
    curl_setopt($chCURLOPT_RETURNTRANSFERfalse);
        
    curl_setopt($chCURLOPT_HEADERfalse);
        
    curl_setopt($chCURLOPT_POSTtrue);
        
    curl_setopt($chCURLOPT_USERAGENT$_SERVER['HTTP_USER_AGENT']);
        
        
    $data = array(
            
    'myfirstvar' => '1'
        
    );
        
        
    curl_setopt($curlCURLOPT_POSTFIELDS$data);
                
        
    $response curl_exec($ch);
        
    curl_close($ch); 
    http page is infinitely waiting of the response.
    Request doesn't come to httpProvider. But GET request runs good.

    my vhost.xml:

    ...
    
    <HTTPProvider>
    	<BaseClass>myPackage.MyApp</BaseClass>
    	<RequestFilters>*myapp</RequestFilters>
    	<AuthenticationMethod>none</AuthenticationMethod>
    </HTTPProvider>
    
    ...

  2. #2

    Default

    problem resolved(syntax error). How can I remove this thread?

  3. #3
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Thanks for the update.
    The thread will be left here for other users to view as it may be helpful.

    Jason

Similar Threads

  1. Reading post variables in HTTPProvider
    By ablankenship in forum Server-side Modules and Code Samples Discussion
    Replies: 3
    Last Post: 10-14-2013, 02:22 AM
  2. How to post a job
    By lisa_w in forum Assistance with live events
    Replies: 0
    Last Post: 01-24-2013, 11:32 AM
  3. How to post a job
    By lisa_w in forum Wowza Streaming Engine functionality
    Replies: 0
    Last Post: 01-24-2013, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •