Results 1 to 6 of 6

Thread: RTMP stream is not working.

  1. #1

    Default RTMP stream is not working.

    Hi,
    I am using Wowza Media Server 2.2.4. now i am trying to restream video from ip camera using following url http://www.wowza.com/forums/content.php?39.
    When i try to play the stream in jwplayer then it will goes to blank stream. But we can play the stream using rtsp(using vlc) and http (iphone) from wowza servers. following are the error message

    ERROR server comment 2013-02-08 04:26:33 - - - - - 11279.655 - - - - - -- - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].
    ERROR server comment 2013-02-08 04:26:43 - - - - - 11289.842 - - - - - -- - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].
    ERROR server comment 2013-02-08 04:26:54 - - - - - 11300.03 - - - - - -- - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].
    ERROR server comment 2013-02-08 04:27:04 - - - - - 11310.218 - - - - - -- - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].

    ip camera --> wowza --> http : working
    ip camera --> wowza --> rtsp : working
    ip camera --> wowza --> rtmp : not working

    any help would be greatly appreciated

  2. #2
    Join Date
    Jul 2012
    Posts
    299

    Default

    Can you play the RTMP stream using one of the players in the [install-dir]/examples?

    -Tim

  3. #3

    Default

    Hi
    I have tried the player in example. but no luck. it went to blank screen. any idea ?

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The "Failed to connect..." messages are the problem. It indicates that Wowza was able to reach the camera but problem authenticating. With basic authentication you can add user name and password inline:

    http://richard:myPassword@[camera-address]

    Richard
    Last edited by rrlanham; 02-08-2013 at 03:09 PM.

  5. #5

    Default

    Hi Richard,
    Thanks for your reply. but i am able to play hls and rtsp stream. only rtmp have the issue. if any authentication issue then it will affect rtsp and hsl too. so how can i able to play the rtsp anf hls stream ?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Do you have a link to the source and stream from Wowza, are they on public IP?

    Restart Wowza, then connect to the camera, then test playback that works and playback that does not work.

    Re-starting Wowza is important for a good test.

    Then zip up and send the /conf and /logs folders to support@wowza.com.

    Include source and Wowza stream URL if public to test.

    Include a link to this thread for reference.

    Richard

Similar Threads

  1. Replies: 7
    Last Post: 04-23-2013, 01:12 PM
  2. my RTMP not working ?
    By mkaioh2 in forum General Forum
    Replies: 3
    Last Post: 05-24-2012, 02:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •