Results 1 to 3 of 3

Thread: MediaCache Can't Resolve HLS Paths

  1. #1

    Default MediaCache Can't Resolve HLS Paths

    I've set my application up so that the only HTTPStreamer is cupertinostreaming. If I access the file through RTMP, it plays just fine. However, if I append "/playlist.m3u8" to the path, Wowza logs that none of the MediaCacheSources can handle the path when I request that file form it.

    I tried commenting out the RandomAccessReader from the configuration to disable using MediaCache then setting the content folder to be the same as the one used by the MediaCacheSource. Both RTMP and HLS methods work in this case.

    What should I be looking for in this case? I dug up some old post with a similar problem, but no resolution was posted.

  2. #2


    Hrm, removing the value for <Prefix> in MediaCache.xml makes the HLS path work. It's weird, though, that if I use a path like "mp4:FAKEPREFIX/file.mp4/playlist.m3u8" it still plays the file, even if FAKEPREFIX really is some nonsense that's nowhere in my configuration or file system.

  3. #3
    Join Date
    Jun 2011


    When playing back using a full url path for streaming ensure that you include _definst_ before the path
    So for example:

    To play HLS using an Apple iOS device or similar:
    The _definst_ is required whenever specifying a fullpath URL like above, whether http or rtmp etc.
    but is not required when specifying the split form for rtmp of:


    So that's why it worked in one case, but not the other.

    Last edited by daren_j; 02-16-2013 at 08:55 AM.

Similar Threads

  1. Replies: 0
    Last Post: 03-28-2014, 04:52 PM
  2. RequestFilter, *, and absolute paths
    By karlrasche in forum General Forum
    Replies: 2
    Last Post: 01-06-2014, 04:18 PM
  3. Modules/Module/Class paths
    By newtriks in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 7
    Last Post: 12-15-2011, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts