Results 1 to 2 of 2

Thread: Trouble with HLS live stream

  1. #1
    Join Date
    Dec 2011
    Posts
    13

    Default Trouble with HLS live stream

    I know I had this working before, but all of the sudden I am having trouble. I am streaming live video from Wirecast to a Wowza 3.5 server on a Windows 2008 r2 machine. I have jwplayer 5 setup to playback the stream in flash with an HLS fallback for ios devices. With my live stream, flash works fine. When I try to access the stream via HLS I get this error now when I view the Wowza terminal after starting up manually:

    WARN server comment stream1hd MediaReaderH264.open[1]: java.io.FileNotFoundExcep
    tion: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\conten
    t\stream1hd (The system cannot find the file specified)
    INFO cupertino connect 1631330351 -
    INFO stream create stream1hd -
    WARN server comment stream1hd MediaReaderH264.open[1]: java.io.FileNotFoundExcep
    tion: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\conten
    t\stream1hd (The system cannot find the file specified)
    ERROR server comment - MediaReaderH264Cupertino.indexFile:java.lang.NullPointerE
    xception
    WARN server comment stream1hd MediaReaderH264.open[1]: java.io.FileNotFoundExcep
    tion: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\conten
    t\stream1hd (The system cannot find the file specified)
    INFO cupertino connect 1005124144 -
    INFO stream create stream1hd -
    WARN server comment stream1hd MediaReaderH264.open[1]: java.io.FileNotFoundExcep
    tion: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\conten
    t\stream1hd (The system cannot find the file specified)
    ERROR server comment - MediaReaderH264Cupertino.indexFile:java.lang.NullPointerE
    xception
    INFO stream destroy stream1hd -
    INFO cupertino disconnect 1631330351 -

    Here is the URL for HLS as specified in a test jwplayer:

    'file': "http://xxx.xxx.xxx.xxx:1935/livesec/stream1hd/playlist.m3u8",

    Using the url directly in Safari on an iPad also no longer works (http://xxx.xxx.xxx.xxx:1935/livesec/.../playlist.m3u8)

    Once again, flash works fine.

    It also works just fine for HLS in a VOD application.

    My live application also used to work, I haven't changed the config file.

    Thanks for any input.

    Barry Bernard

  2. #2
    Join Date
    Dec 2011
    Posts
    13

    Default

    oops, never mind. Needed to enable cupertinostreamingpacketizer in the app config. Not sure why it ever worked before.

Similar Threads

  1. Live stream HLS repeat stream in a duration (not live)
    By lee2510 in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 07-16-2013, 06:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •