Results 1 to 4 of 4

Thread: After changing stream protocol from rtmp to rtmpt, my player returns a random number

  1. #1
    Join Date
    Dec 2012
    Posts
    3

    Exclamation After changing stream protocol from rtmp to rtmpt, my player returns a random number

    Hi,

    We're using Wowza Media Server 3.5.0.01 build3284 to develop the project.

    We have a player.html containing Flash to call video stream based on Wowza Media Server. And on server side, we have a self-implemented NbrServiceHttpProvider. After changing calling URL from RTMP to RTMPT, once refreshing the html, the page returns a random number on IE8, such as 1057196950.

    Please see the following HTTP headers for the different cases.

    [Correct response]


    [Wrong response]


    Could you please help to address the cause? And anything needs me to provide?

    Thanks,
    -Adam
    Last edited by adam_zhou; 03-06-2013 at 07:13 PM.

  2. #2
    Join Date
    May 2011
    Posts
    456

    Default

    Adam,
    I think you may have meant to post in the Wowza Media Server forum area. This area, where you posted, is for describing jobs which you wish to hire an external consultant.

    This looks like a pipelining issue. HTTP calls need to be make on a separate TCP socket connection from the RTMPT connection. The sample number you referenced is the Wowza session ID. If you have further technical support questions, please post here instead.

    -Lisa

  3. #3
    Join Date
    Dec 2012
    Posts
    3

    Default

    Thank you lisa_w. I will post it on the place you told.

  4. #4

    Default

    Please see here, http://www.wowza.com/forums/showthre...-random-number for an explanation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •