Results 1 to 4 of 4

Thread: Audio Streaming with Video Component

  1. #1
    Join Date
    Mar 2013
    Posts
    9

    Default Audio Streaming with Video Component

    Hi,

    I have an audio stream being reproduced in multiple players, some of them developed by other companies than mine.
    Several player developers are calling me, telling that there is a video compontent on my audio stream.
    I am forwarding my transcoder code below:

    <!-- Example template for transrate, producing four new streams at different bitrates. Resultant streams can be played back individually or as a group. source, 360p and 160p encode blocks are enabled through the Enable property, other examples are not enabled. Add additional encode blocks to your template as needed. -->
    <Root>
    <Transcode>
    <Encodes>
    <!-- Example Encode block for source, not required unless Member of StreamNameGroup. -->
    <Encode>
    <Enable>true</Enable>
    <Name>source</Name>
    <StreamName>mp3:${SourceStreamName}_source</StreamName>
    <Video>
    <Codec>Disable</Codec>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <Encode>
    <Enable>true</Enable>
    <Name>72k</Name>
    <StreamName>mp3:${SourceStreamName}_72k</StreamName>
    <Video>
    <Codec>Disable</Codec>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>72000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <Encode>
    <Enable>true</Enable>
    <Name>48k</Name>
    <StreamName>mp3:${SourceStreamName}_48k</StreamName>
    <Video>
    <Codec>Disable</Codec>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <Encode>
    <Enable>true</Enable>
    <Name>aac</Name>
    <StreamName>${SourceStreamName}_aac</StreamName>
    <Video>
    <!-- H.264, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceVideoBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    </Encodes>
    <StreamNameGroups>
    <!-- Note: Play stream using stream name ngrp:[stream-name] -->
    <StreamNameGroup>
    <Name>${SourceStreamName}_all</Name>
    <Members>
    <Member>
    <EncodeName>source</EncodeName>
    </Member>
    <Member>
    <EncodeName>72k</EncodeName>
    </Member>
    <Member>
    <EncodeName>48k</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    </StreamNameGroups>
    <Properties>
    </Properties>
    </Transcode>
    </Root>

    Checking the input source, i can see it's a pure mp3 in VLC player (MPEG audio layer 1-2-3). However, even if I stream just the source signal, it arrives on players with a video component (according to the developers).

    Do you know what can it be?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The "AAC" encode has the /Video /Codec set to "PassThru", change that to "Disable" as you have in the other /Encode blocks.

    Richard

  3. #3
    Join Date
    Mar 2013
    Posts
    9

    Default

    Ahhh, of course!
    Thanks Richard!

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You're welcome. Thanks for the update,

    Richard

Similar Threads

  1. Looking for a Flash component that be embeded into web page for streaming
    By andyww in forum Live Streaming and Encoders
    Replies: 7
    Last Post: 10-22-2014, 09:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •