Results 1 to 4 of 4

Thread: cant get my live stream to work:(

  1. #1
    Join Date
    Mar 2013
    Posts
    3

    Default cant get my live stream to work:(

    hi guys,

    i followd the tutorials and multiple pages but for some reason it aint working for me.

    we have a axis p5512 and a axis 215 ptz

    and we would like to put a live view of 1 of those camera`s on our website (made in wordpress)

    from what i read i need to put it on streamtype live? but i could be wrong:)

    below ill add the codes i have in my wowza.

    applications\live\live.stream
    {
        uri:"rtsp://[username:password@ipadres from camera]:554/axis-media/media.amp ",
        streamTimeout:5000,
        reconnectWaitTime:3000,
        rtpTransportMode:"udp",
        rtspValidationFrequency:15000,
        rtspFilterUnknownTracks:true,
        rtspStreamAudioTrack:false,
        rtspStreamVideoTrack:true,
        rtpDebugSession:true,    
        rtpIgnoreProfileLevelId:true,
        rtpIgnoreSPropParameterSets:true,
        rtspBindIpAddress:"192.168.1.90",,			(IP adres from my local computer)
        rtspRemoveUserInfo:true,
        rtspSessionTimeout:10000,
        rtspConnectionTimeout:10000
    }
    conf\live\application.xml

    <Root>
    	<Application>
    		<!-- Uncomment to set application level timeout values
    		<ApplicationTimeout>60000</ApplicationTimeout>
    		<PingTimeout>12000</PingTimeout>
    		<ValidationFrequency>8000</ValidationFrequency>
    		<MaximumPendingWriteBytes>0</MaximumPendingWriteBytes>
    		<MaximumSetBufferTime>60000</MaximumSetBufferTime>
    		<MaximumStorageDirDepth>25</MaximumStorageDirDepth>
    		-->
    		<Connections>
    			<AutoAccept>true</AutoAccept>
    			<AllowDomains></AllowDomains>
    		</Connections>
    		<!--
    			StorageDir path variables
    			
    			${com.wowza.wms.AppHome} - Application home directory
    			${com.wowza.wms.ConfigHome} - Configuration home directory
    			${com.wowza.wms.context.VHost} - Virtual host name
    			${com.wowza.wms.context.VHostConfigHome} - Virtual host config directory
    			${com.wowza.wms.context.Application} - Application name
    			${com.wowza.wms.context.ApplicationInstance} - Application instance name
    			
    		-->
    		<Streams>
    			<StreamType>live</StreamType>
    			<StorageDir>${com.wowza.wms.context.VHostConfigHome}/content</StorageDir>
    			<KeyDir>${com.wowza.wms.context.VHostConfigHome}/keys</KeyDir>
    			<!-- LiveStreamPacketizers (separate with commas): cupertinostreamingpacketizer, smoothstreamingpacketizer, sanjosestreamingpacketizer, cupertinostreamingrepeater, smoothstreamingrepeater, sanjosestreamingrepeater -->
    			<LiveStreamPacketizers>cupertinostreamingpacketizer,smoothstreamingpacketizer,sanjosestreamingpacketizer</LiveStreamPacketizers>			
    			<!-- Properties defined here will override any properties defined in conf/Streams.xml for any streams types loaded by this application -->
    			<Properties>
    			</Properties>
    		</Streams>
    		<!-- HTTPStreamers (separate with commas): cupertinostreaming, smoothstreaming, sanjosestreaming -->
    		<HTTPStreamers>cupertinostreaming,smoothstreaming,sanjosestreaming</HTTPStreamers>			
    		<SharedObjects>
    			<StorageDir></StorageDir>
    		</SharedObjects>
    		<Client>
    			<IdleFrequency>-1</IdleFrequency>
    			<Access>
    				<StreamReadAccess>*</StreamReadAccess>
    				<StreamWriteAccess>*</StreamWriteAccess>
    				<StreamAudioSampleAccess></StreamAudioSampleAccess>
    				<StreamVideoSampleAccess></StreamVideoSampleAccess>
    				<SharedObjectReadAccess>*</SharedObjectReadAccess>
    				<SharedObjectWriteAccess>*</SharedObjectWriteAccess>
    			</Access>
    		</Client>
    		<RTP>
    			<!-- RTP/Authentication/[type]Methods defined in Authentication.xml. Default setup includes; none, basic, digest -->
    			<Authentication>
    				<PublishMethod>digest</PublishMethod>
    				<PlayMethod>none</PlayMethod>
    			</Authentication>
    			<!-- RTP/AVSyncMethod. Valid values are: senderreport, systemclock, rtptimecode -->
    			<AVSyncMethod>senderreport</AVSyncMethod>
    			<MaxRTCPWaitTime>12000</MaxRTCPWaitTime>
    			<IdleFrequency>75</IdleFrequency>
    			<RTSPSessionTimeout>90000</RTSPSessionTimeout>
    			<RTSPMaximumPendingWriteBytes>0</RTSPMaximumPendingWriteBytes>
    			<RTSPBindIpAddress></RTSPBindIpAddress>
    			<RTSPConnectionIpAddress>0.0.0.0</RTSPConnectionIpAddress>
    			<RTSPOriginIpAddress>127.0.0.1</RTSPOriginIpAddress>
    			<IncomingDatagramPortRanges>*</IncomingDatagramPortRanges>
    			<!-- Properties defined here will override any properties defined in conf/RTP.xml for any depacketizers loaded by this application -->
    			<Properties>
    			</Properties>
    		</RTP>
    		<MediaCaster>
    			<!-- Properties defined here will override any properties defined in conf/MediaCasters.xml for any MediaCasters loaded by this applications -->
    			<Properties>
    				<Property>
    				    <Name>forceInterleaved</Name>
    				    <Value>true</Value>
    				    <Type>Boolean</Type>
    				</Property>			
    			</Properties>
    		</MediaCaster>
    		<MediaReader>
    			<!-- Properties defined here will override any properties defined in conf/MediaReaders.xml for any MediaReaders loaded by this applications -->
    			<Properties>
    			</Properties>
    		</MediaReader>
    		<MediaWriter>
    			<!-- Properties defined here will override any properties defined in conf/MediaWriter.xml for any MediaWriter loaded by this applications -->
    			<Properties>
    			</Properties>
    		</MediaWriter>
    		<LiveStreamPacketizer>
    			<!-- Properties defined here will override any properties defined in conf/LiveStreamPacketizers.xml for any LiveStreamPacketizers loaded by this applications -->
    			<Properties>
    			</Properties>
    		</LiveStreamPacketizer>
    		<HTTPStreamer>
    			<!-- Properties defined here will override any properties defined in conf/HTTPStreamers.xml for any HTTPStreamer loaded by this applications -->
    			<Properties>
    			</Properties>
    		</HTTPStreamer>
    		<Repeater>
    			<OriginURL></OriginURL>
    			<QueryString><![CDATA[]]></QueryString>
    		</Repeater> 
    		<Modules>
    			<Module>
    				<Name>base</Name>
    				<Description>Base</Description>
    				<Class>com.wowza.wms.module.ModuleCore</Class>
    			</Module>
    			<Module>
    				<Name>properties</Name>
    				<Description>Properties</Description>
    				<Class>com.wowza.wms.module.ModuleProperties</Class>
    			</Module>
    			<Module>
    				<Name>logging</Name>
    				<Description>Client Logging</Description>
    				<Class>com.wowza.wms.module.ModuleClientLogging</Class>
    			</Module>
    			<Module>
    				<Name>flvplayback</Name>
    				<Description>FLVPlayback</Description>
    				<Class>com.wowza.wms.module.ModuleFLVPlayback</Class>
    			</Module>
    		</Modules>
    		<!-- Properties defined here will be added to the IApplication.getProperties() and IApplicationInstance.getProperties() collections -->
    		<Properties>
    		</Properties>
    	</Application>
    </Root>

    if you need more just give me a shout and i give u all the info needed:)
    exept the ip adres from the camera :)


    i did start the stream in the stream manager,
    also tryed to use the rtp-live
    sofar no luck:(

    i'm guessing its something silly that i overlooked but you will probably point that out for me:)
    thanks in advance!

  2. #2
    Join Date
    Mar 2013
    Posts
    3

    Default

    i forgot to mention that i did have a live stream in the wowza page but as stream i used the rtsp adres of the camera itself.
    i never got the live.stream file to work. or i forgot to enable something on the camera or i overlooked a setting in the configuration but i went over the tutorial pages several times.

    i must say i am dyslectic so bare with me if i read over some important things,

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You have to start stream name "live.stream" in StreamManager or /conf/StartUpStreams.xml with MediaCaster type "rtp"

    http://www.wowza.com/forums/content....-re-streaming)

    Make sure the file /content/live.stream doesn't have a .txt extension.

    Richard

  4. #4
    Join Date
    Mar 2013
    Posts
    3

    Default

    I have started the stream in the stream manager, but still no screen in the startup page that wowza opens.

    It does not have an txt extension

    I tried the rtsp url from the camera in vlc and it can open the live stream

    I will read on the link tomorrow, checking on my iphone now, 00:06 here atm
    Thanks for your reply,


    If any one feels like it i could setup a teamviewer session at a given time if that makes things easyer.

    Thanks again in advance!

    edit:
    i just checked the link you posted, and i have read and followed that link earlyer.

    thanks again!

    Figured it out!
    changed the live.stream contents to just the rtsp adres and it works now

    now all i have to do is find a way to stream to our website wich also works for mobile devices.
    Last edited by darkalien; 03-19-2013 at 06:33 AM. Reason: Extra info

Similar Threads

  1. Live Stream with adaptive bitrate, work not well
    By topkarr in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 09-17-2012, 10:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •