Results 1 to 4 of 4

Thread: Support for multiple SPS/PPS in MP4 file streaming containing H264 encoded video

  1. #1
    Join Date
    Mar 2013
    Posts
    7

    Default Support for multiple SPS/PPS in MP4 file streaming containing H264 encoded video

    Hi,

    Seeing corrupt video of mp4 file on flash player streamed via Wowza which has two SPS and PPS units.
    I would like to know if Wowza supports multiple SPS/PPS NAL units for streaming H264 video and AAC audio in MP4 container format. My MP4 file has two different SPS/PPS units with sps-id/pps-id 0 and 1 respectively as part of avcC atom. H264 Video profile, level and resolution in these SPS/PPSs are same, and different parts of encoded video point to these.

    - Hitesh

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Hitesh,

    No, sorry, Wowza does not support this.

    Richard

  3. #3
    Join Date
    Mar 2013
    Posts
    7

    Default

    Thanks Richard for your quick response.
    What I have observed is if I seek any where on this video then it plays fine both the video parts pointing to different sets of SPS/PPS. Without any seek event video play with artifacts. Does seek provide flash player with some extra information that it starts playing fine after that?

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    If that's true then you could force the player to seek to 00:00 when a play request comes in which should solve the problem...
    Let us know how you get on if you choose to try it.

    Jason

Similar Threads

  1. sending sps and pps in band
    By srikanth.vukkadapu in forum General Forum
    Replies: 1
    Last Post: 12-17-2013, 08:13 AM
  2. How can I log NAL PPS and SPS?
    By danscan in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 07-17-2013, 06:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •