Results 1 to 5 of 5

Thread: iOS HTTP streaming playback failure

  1. #1
    Join Date
    Mar 2013
    Posts
    2

    Default iOS HTTP streaming playback failure

    I have created an UDP to HTTP video re-stream that has the video layer encoded in H.264 MPEG 4 and audio encoded in Mpeg AAC 48000 128 kbps.

    When I try to play this stream in iOS, there's only audio and no video.
    VLC plays it well. Quicktime can't play it at all.

    the playlist.m3u8 looks like this:
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=2968468,CODECS="avc1.100.30, mp4a.40.2",RESOLUTION=785x576
    chunklist.m3u8?wowzasessionid=837649857


    When I enable transrating(not transcoding) and specify H.264 for the video, it plays well. but the server consumes a lot of resources.
    The transcoded playlist.m3u8 looks like this:
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=572079,CODECS="avc1.66.30, mp4a.40.2",RESOLUTION=424x240
    chunklist.m3u8?wowzasessionid=1305303354


    Can anyone tell me what's wrong here and what can be done without transcoding?
    Last edited by grossum; 03-20-2013 at 07:51 PM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I think avc.100.30 is High Profile, which is not supported in most or all iOS devices. You want Main (avc.77.30) or Baseline Profile (avc.66.30)

    http://www.wowza.com/forums/content....to-iOS-streams

    Richard

  3. Default

    Quote Originally Posted by rrlanham View Post
    I think avc.100.30 is High Profile, which is not supported in most or all iOS devices. You want Main (avc.77.30) or Baseline Profile (avc.66.30)

    http://www.wowza.com/forums/content....to-iOS-streams

    Richard
    I have same problem although my video codec is (avc.77.30). I have only audio and no video. this is my playlist.m3u8. any sugestion? is my resolition is important?
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=1984015,CODECS="avc1.77.30, mp4a.40.2",RESOLUTION=785x576
    chunklist_w1274697623.m3u8

  4. #4

    Default

    Quote Originally Posted by yee.woon2@gmail.com View Post
    I have same problem although my video codec is (avc.77.30). I have only audio and no video. this is my playlist.m3u8. any sugestion? is my resolition is important?
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=1984015,CODECS="avc1.77.30, mp4a.40.2",RESOLUTION=785x576
    chunklist_w1274697623.m3u8
    Hi,

    I am facing the same problem.

    Did you find any solution?

    Regards,

    Manu

  5. #5
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    avc1.77.30 is Main profile level 3.0. and should play on most device recent devices.
    You said Audio only, but CODECS="avc1.77.30, mp4a.40.2",RESOLUTION=785x576
    does certainly indicate the presence of video. So you can only hear audio?

    How are you both creating your streams, what is the original source?

    Daren

Similar Threads

  1. http ios streaming issue via wifi
    By hdesigns in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 01-14-2013, 12:40 PM
  2. Restreaming RTMP to iOS - intermittent failure
    By Chingo in forum Live Streaming and Encoder Discussion
    Replies: 5
    Last Post: 12-16-2011, 05:46 AM
  3. HTTP Streaming, iOS and vods3. Are all these work together?
    By greenf in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 11-01-2011, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •