Results 1 to 4 of 4

Thread: Corrupt recordings from webcam source

  1. #1
    Join Date
    Nov 2010
    Posts
    4

    Default Corrupt recordings from webcam source

    Hello,
    I am working with Wowza 3.5 and have a problem that is haunting me the last couple of weeks:
    The recorded files sometimes work, but randomly have following issues:
    - Video for a couple of seconds than only audio
    - Frozen video frame for the first seconds, than everything ok
    - no video at all.

    I use a webcam to record a stream. On the clientside I have a Flex 4.6 generated SWF and on the serverside a pretty standard "record" streamtype.
    The Flex 4.6 app publishes an mp4 stream with Speex Codec. I issue the publish command various times during a Netstream session as I want different files for each segment. Could this be the problem? Currently I have a Netstream buffer to compensate bandwidth problems and only close the Netstream when the buffer is empty to ensure that the file gets written completely. After the Netstream is closed, I publish a different mp4. Are these commands supported in this way with Wowza?

    The server runs on a micro EC2 instance for testing purposes. I did not use the Wowza AMI. However I also experienced the same issues on my mac with the server running locally.

    Thank you for any help!

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Does your Flex app unpublish the stream when the buffer is empty?, this will then allow Wowza to close the recording correctly which could resolve this if it wasn't being done.
    If you change the streamType to "live-record" you will be able to see if the stream plays fine before it's been recorded to rule out the stream itself.

    I also recommend using mp3 audio if you can as it's a more compatible codec.

    Jason

  3. #3
    Join Date
    Nov 2010
    Posts
    4

    Default

    Hello Jason,

    thank you for your fast response. I issue a close() on the netstream which is supposed to stop the publishing according to the Adobe AS3 docs. In theory I can use the same stream to publish again. is this enough?

    Kai


    Quote Originally Posted by JasonH View Post
    Hi
    Does your Flex app unpublish the stream when the buffer is empty?, this will then allow Wowza to close the recording correctly which could resolve this if it wasn't being done.
    If you change the streamType to "live-record" you will be able to see if the stream plays fine before it's been recorded to rule out the stream itself.

    I also recommend using mp3 audio if you can as it's a more compatible codec.

    Jason

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Take a look at the modified version of the VideoChat example in this article as a starting place or reference:

    http://www.wowza.com/forums/content....anscoder-AddOn

    Richard

Similar Threads

  1. MP4 file corrupt
    By Bernienor in forum General Forum
    Replies: 2
    Last Post: 06-02-2014, 01:28 AM
  2. HTTPLiveStreamRecord Generating Corrupt Files
    By ImAStreamer in forum General Forum
    Replies: 5
    Last Post: 03-20-2014, 09:25 PM
  3. passthrough video frozen and/or corrupt when saved
    By smaddock in forum AddOn: Transcoder
    Replies: 2
    Last Post: 05-21-2012, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •