Results 1 to 2 of 2

Thread: "Not licensed for HTTPOrigin mode" error on Wowza EC2 AMI

  1. #1
    Join Date
    Apr 2013

    Default "Not licensed for HTTPOrigin mode" error on Wowza EC2 AMI

    I am using AMI Id ami-c2fd6dab, which comes under the "Bring Your Own (LicKey)" AMI type. I am able to launch the AMI and stream from the server.

    I am trying to configure HTTPOrigin mode on the server, and I get this error in the logs.

    ERROR HTTPUtils.HTTPRequestToByteArray:
    WARN  HTTPStreamerApplicationContextBase.init: Not licensed for HTTPOrigin mode: HTTPStreamerApplicationContextSmoothStreamer
    What is the default licence on these AMIs? What do I need to do in order to enable HTTPOrigin mode functionality.

  2. #2
    Join Date
    Sep 2011


    The Lickey AMIs give you a development license by default and this comes with its restrictions.
    The daily, monthly or perpetual will allow HTTPOrigin mode to be activated.

    Please find the license restrictions here,


Similar Threads

  1. Replies: 1
    Last Post: 05-18-2014, 04:00 PM
  2. Replies: 4
    Last Post: 06-15-2012, 09:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts