Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: httm smil patch

  1. #1

    Default httm smil patch

    hi,
    Adobe fmle (multi bitrate)- encode
    test play strobe.

    If put stream.smil into content -

    http://localhost:1935/live/stream.smil/manifest.f4m - work fine!
    If create folder content/0/ and put into stream.smil
    play
    http://localhost:1935/live/0/stream.smil/manifest.f4m - #2032 stream error!
    why?

    Thanks.
    Last edited by pidboretskyy; 05-01-2013 at 11:38 AM.

  2. #2

    Default

    try it like this:
    http://localhost:1935/live/_definst_...l/manifest.f4m

    You need to reference an application instance when your accessing a subfolder, and _definst_ is the default application instance if none is specified.

  3. #3

  4. #4

    Default

    start wowza in stand-alone (/bin/startup.bat) mode and see what it says in the console when you test

    Salvadore

  5. #5

    Default

    invoke(onHTTPSessionCreate): java.lang.NullPointerException: com.itbom.http.StartLive.onHTTPSessionCreate(StartLive.java:63)
    WARN	server	comment	2013-05-01	22:08:49	-	-	-	-	-	38.942	-	-	-	-	-	-	-	-	HTTPStreamerAdapterSanJoseStreamer.getAppInstance: Stream not found [live/_definst_/0/stream.smil/manifest.f4m]: live/stream.smil

  6. #6

    Default

    this is working now that you removed the .../0/... from the url, correct?

    Salvadore

  7. #7

    Default

    if removed /0/ - work fine

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What is shown in the log messages? Wowza log messages will show you exactly where it is looking for the file. What do you see in the console when you try to play the file in the subfolder using "_definst_" in the url?

    Richard

  9. #9

    Default

    2013-05-01	22:36:32	CEST	connect	sanjose	INFO	200	1797896655	-	_defaultVHost_	live	_definst_	26.563	domain.com	1935	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m	46.175.145.129	http (sanjose)	-	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/536.29.13 (KHTML, like Gecko) Version/6.0.4 Safari/536.29.13	1797896655	0	0	-	0	-	-	0/stream.smil	-	-	-	-	-	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m	-	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m	-
    2013-05-01	22:36:32	CEST	create	stream	INFO	200	0/stream.smil	-	_defaultVHost_	live	_definst_	0.001	domain.com	1935	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m	46.175.145.129	http (sanjose)	-	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/536.29.13 (KHTML, like Gecko) Version/6.0.4 Safari/536.29.13	1797896655	0	0	1	0	0	0	0/stream.smil	-	-	-	-	-	http://domain.com:1935/live/_definst_/0/stream.smil/manifest.f4m
    
    2013-05-01	22:36:32	CEST	comment	server	WARN	200	-	HTTPStreamerAdapterSanJoseStreamer.getAppInstance: Stream not found [/live/_definst_/0/stream.smil/manifest.f4m]: live/max.smil	-	-	-	26.591	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
    2013-05-01	22:36:39	CEST	comment	server	INFO	200	-	LiveStreamPacketizerSanJose.endChunkTS[live/_definst_/stream1]: Add chunk: id:2 a/v/k:0/251/2 duration:21014	-	-	-	47.437	-	-	-	-	-	-	-	-	-	-	-
    Last edited by pidboretskyy; 05-01-2013 at 01:42 PM.

  10. #10

    Default

    now work.
    thanks.
    Last edited by pidboretskyy; 05-01-2013 at 02:14 PM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Stream not found [live/smil:myStream.smil/manifest.f4m]: myStream.smil
    By viet_fpt in forum Live Streaming and Encoder Discussion
    Replies: 12
    Last Post: 04-08-2013, 07:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •