Results 1 to 5 of 5

Thread: jwplayer6 reporting bitrates wrong from WowzaMediaServer jwplayer.smil

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    May 2013
    Posts
    4

    Default jwplayer6 reporting bitrates wrong from WowzaMediaServer jwplayer.smil

    JWPlayer6 erroneously populates the bitrate selector on the stream we are playing back as follow:

    Auto
    0kbps
    1kbps
    1kbps
    2kbps
    3kbps
    Loaded using:

    'playlist': [{ 'sources': [{ 'file': 'http://1.2.3.4:1935/ourvideo/smil:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41.smil/jwplayer.smil' }] }],
    Using RTMP with Wowza 3.2.5, the generated jwplayer.smil is as follows:

    <smil>
    <head>
    <meta base="rtmp://1.2.3.4:1935/ourvideo"/>
    </head>
    <body>
    <switch>
    <video src="mp4:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41-400k.mp4" system-bitrate="400"/>
    <video src="mp4:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41-800k.mp4" system-bitrate="800"/>
    <video src="mp4:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41-1200k.mp4" system-bitrate="1200"/>
    <video src="mp4:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41-2000k.mp4" system-bitrate="2000"/>
    <video src="mp4:499ba4b9-149e-427e-87bc-441820a99fa0/output_2013-05-07_18-41-41-3500k.mp4" system-bitrate="3500"/>
    </switch>
    </body>
    </smil>
    The original SMIL passed to wowza was:

    <smil><head></head><body><switch>
    <video src="mp4:output_2013-05-07_18-41-41-400k.mp4" system-bitrate="400000"/>
    <video src="mp4:output_2013-05-07_18-41-41-800k.mp4" system-bitrate="800000"/>
    <video src="mp4:output_2013-05-07_18-41-41-1200k.mp4" system-bitrate="1200000"/>
    <video src="mp4:output_2013-05-07_18-41-41-2000k.mp4" system-bitrate="2000000"/>
    <video src="mp4:output_2013-05-07_18-41-41-3500k.mp4" system-bitrate="3500000"/>
    </switch></body></smil>
    Clearly Wowza has divided them down by 1000, it also seems to do that for the .rss files too. However jwplayer doesn't seem to want this behaviour in this case.

    How can we stop Wowza dividing them down in this way, or persuade jwplayer6 to understand they are kbits rather then bits?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It should be fixed in this patch:

    http://www.wowza.com/downloads/Wowza...5.2-patch8.zip

    Thanks for the report,
    Richard

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It is fixed with that patch in my test.

    Richard

  4. #4
    Join Date
    May 2013
    Posts
    4

    Default

    Yes that patch resolves the issue thanks.

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You're welcome. Thanks for the update

    Richard

Similar Threads

  1. Replies: 2
    Last Post: 06-16-2014, 07:25 AM
  2. jwplayer.smil broken
    By saxonytv in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 08-25-2013, 12:49 AM
  3. force rtmpt in SMIL generated by jwplayer.smil?
    By SONIC-HZ in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 05-14-2013, 07:39 AM
  4. smil on s3 with JWPlayer 6
    By jeepsterryan in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 4
    Last Post: 03-27-2013, 09:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •