Results 1 to 3 of 3

Thread: Problem on Jconsole Startup

  1. #1
    Join Date
    Apr 2013
    Posts
    16

    Default Problem on Jconsole Startup

    Hi Wowza team

    I just got some problem on Jconsole since I am using Virtual private server to run Wowza.
    The configuration on Server.html is here.

    </AdminInterface>
    <!-- JMXUrl: service:jmx:rmi://122.155.15.xxx:8084/jndi/rmi://122.155.15.xxx:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>true</Enable>
    <IpAddress>122.155.15.xxx</IpAddress> <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>122.155.15.xxx</RMIServerHostName> <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>

    However, I got the error during running Jconsole and the error has been shown

    ERROR 500 - JMXConfig: error: java.io.IOException: Cannot bind to URL [rmi://122.155.15.xxx:8085/jmxrmi]: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: 122.155.15.xxx; nested exception is:
    java.net.ConnectException: Connection timed out: connect]


    Port 8084 and 8085 have been opened already but still cannot access to Jconsole.
    Could you please help me figure out?

    Thanks
    Mark

  2. #2

    Default

    Hi there, it looks like you are trying to run jconsole at the same location as your wowza install?

    Can you get it to work if you set authenticate to false <Authenticate>false</Authenticate> and use the default url to connect? :
    service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi

    This just worked for me

    Salvadore

  3. #3

    Default

    I did a little more work with this, and also realized its not a good idea to not use authentication.

    So leave authentication enabled, use the default url: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi
    and the default user name is: admin and password: admin

    Also make sure wowza is started.

    You could work through this guide to make sure you are setting this up correctly,

    Enable JMX in Wowza Media Server

    Salvadore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •