Results 1 to 2 of 2

Thread: Wowza server only finding first vhost in VHosts.xml

  1. #1
    Join Date
    May 2013
    Posts
    1

    Default Wowza server only finding first vhost in VHosts.xml

    I have wowza running on a CentOS machine. I notice that now only the first vhost lists in VHosts.xml is working. Here's my settings:

    /usr/local/WowzaMediaServer/conf/VHosts.xml
    <Root>
          	<VHosts>
                    <VHost>
                           	<Name>wowzatest</Name>
                            <ConfigDir>/home/wowzatest</ConfigDir>
                            <ConnectionLimit>0</ConnectionLimit>
                    </VHost>
    
                    <VHost>
                           	<Name>nola123</Name>
                            <ConfigDir>/home/nola123</ConfigDir>
                            <ConnectionLimit>0</ConnectionLimit>
                    </VHost>
            </VHosts>
    </Root>

    /home/wowzatest/conf/VHost.xml
    <Root>
          	<VHost>
                   	<HostPortList>
                            <HostPort>
                                    <ProcessorCount>4</ProcessorCount>
                                    <IpAddress>173.x.x.12</IpAddress>
                                    <!-- Separate multiple ports with commas -->
                                    <!-- 80: HTTP, RTMPT -->
                                    <!-- 554: RTSP -->
                                    <Port>5000</Port>
                                    <SocketConfiguration>
                                            <ReuseAddress>true</ReuseAddress>
                                            <!-- suggested settings for video on demand applications -->
                                            <ReceiveBufferSize>65000</ReceiveBufferSize>
                                            <ReadBufferSize>65000</ReadBufferSize>
                                            <SendBufferSize>65000</SendBufferSize>
                                            <!-- suggest settings for low latency chat and video recording appli$
                                            <ReceiveBufferSize>32000</ReceiveBufferSize>
                                            <ReadBufferSize>32000</ReadBufferSize>
                                            <SendBufferSize>32000</SendBufferSize>
                                            -->
                                            <KeepAlive>true</KeepAlive>
                                            <!-- <TrafficClass>0</TrafficClass> -->
                                            <!-- <OobInline>false</OobInline> -->
                                            <!-- <SoLingerTime>-1</SoLingerTime> -->
                                            <!-- <TcpNoDelay>false</TcpNoDelay> -->
                                            <AcceptorBackLog>100</AcceptorBackLog>
                                    </SocketConfiguration>
                                    <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,$
                                    <HTTPProviders>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
                                                    <RequestFilters>*crossdomain.xml</RequestFilters>
    etc...

    /home/nola123/conf/VHost.xml
    <Root>
          	<VHost>
                   	<HostPortList>
                            <HostPort>
                                    <ProcessorCount>4</ProcessorCount>
                                    <IpAddress>173.x.x.12</IpAddress>
                                    <!-- Separate multiple ports with commas -->
                                    <!-- 80: HTTP, RTMPT -->
                                    <!-- 554: RTSP -->
                                    <Port>5150</Port>
                                    <SocketConfiguration>
                                            <ReuseAddress>true</ReuseAddress>
                                            <!-- suggested settings for video on demand applications -->
                                            <ReceiveBufferSize>65000</ReceiveBufferSize>
                                            <ReadBufferSize>65000</ReadBufferSize>
                                            <SendBufferSize>65000</SendBufferSize>
                                            <!-- suggest settings for low latency chat and video recording appli$
                                            <ReceiveBufferSize>32000</ReceiveBufferSize>
                                            <ReadBufferSize>32000</ReadBufferSize>
                                            <SendBufferSize>32000</SendBufferSize>
                                            -->
                                            <KeepAlive>true</KeepAlive>
                                            <!-- <TrafficClass>0</TrafficClass> -->
                                            <!-- <OobInline>false</OobInline> -->
                                            <!-- <SoLingerTime>-1</SoLingerTime> -->
                                            <!-- <TcpNoDelay>false</TcpNoDelay> -->
                                            <AcceptorBackLog>100</AcceptorBackLog>
                                    </SocketConfiguration>
                                    <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,$
                                    <HTTPProviders>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
                                                    <RequestFilters>*crossdomain.xml</RequestFilters>
    etc...

    Ports 5150 and 5000 are opened in the firewall (and even firewall is disabled.) Only 5000 works. If I swap the entries in VHosts.xml around, then 5150 works, but not 5000. I'm restarting '/etc/init.d/WowzaMediaServer restart' each time.

  2. #2

    Default

    At a guess you have not changed the other ports in the VHost.xml file. There is also 8086 by default, so the second VHost wont start as it cant bind to 8086 as well. Change 8086 to 8087 in the /home/nola123/conf/VHost.xml file and it should allow both to start.

    Andrew.

Similar Threads

  1. What does IdleWorkers in Vhosts.xml do?
    By Bencredible in forum Performance Tuning Discussion
    Replies: 4
    Last Post: 08-05-2013, 08:52 AM
  2. Replies: 15
    Last Post: 02-21-2013, 03:57 PM
  3. Multiple VHosts to single VHost conversion, content addressing help please
    By lillereven in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 10-01-2012, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •