Results 1 to 6 of 6

Thread: turn off livestreamautorecording on wowza 3.5

  1. #1
    Join Date
    May 2013
    Posts
    17

    Default turn off livestreamautorecording on wowza 3.5

    We are using wowza 2.2.4 for live streaming and recording on demand using HTTPprovider.

    Now we are switching to wowza 3.5 for watermarking.
    In wowza 3.5 videos are getting recorded automatically when live stream starts. We want recording only when we call start recoding using httpprovider programatically.

    Can we turn off this auto recording for live stream for wowza 3.5 ?

  2. Default

    In the Application.xml of your application (e.g. [install-dir]/conf/live/Application.xml), check the value for Streams/StreamType. If this is rtp-live-record or live-record, the stream will be automatically recorded when it's started. You can change this to rtp-live or live to disable automatic recording.

  3. #3
    Join Date
    May 2013
    Posts
    17

    Default

    I have set StreamTypelive to live in [install-dir]/conf/live/Application.xml. still it is recording streams .
    Even though on demand recording is stopped videos are getting recorded with file name cameraid_20130530115548_2013-05-30-12.00.35.942-IST_0.mp4

  4. Default

    Did you restart the application after the change? You don't have to restart the entire Wowza server, you can restart a single application via JConsole (see http://www.wowza.com/forums/showthre...rt-Application)

  5. #5
    Join Date
    May 2013
    Posts
    17

    Default

    Thanks for quick reply.

    Yes I restarted wowza service many times.
    For this issue i changed base class for liverecorder.
    But after that I am getting below error in /home/wowza/logs/wowzamediaserver_error.log
    HTTPStreamerAdapterCupertinoStreamer.canHandle[loadbalancer]: false
    INFO server comment 2013-05-30 14:16:40 - - - - - 59.673 - - - - - - - -HTTPStreamerAdapterSanJoseStreamer.canHandle[loadbalancer]: false

  6. #6
    Join Date
    May 2013
    Posts
    17

    Default

    Thanks for help
    Issue got resolved

    I did not change base class info for HTTPLiveStreamRecord . hence it was using default HTTPLiveStreamRecord .
    Now I changed to custom base class and every thing is working fine.

Similar Threads

  1. Wowza Server is temporarily down when I turn off and turn on Wowza Load test Tool
    By hungnguyen88 in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 09-12-2014, 02:17 AM
  2. How to turn off new modules in 4.0.1
    By terbooter in forum General Forum
    Replies: 2
    Last Post: 03-18-2014, 11:46 PM
  3. Replies: 1
    Last Post: 07-31-2013, 06:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •