Results 1 to 3 of 3

Thread: Is it possible to recors with frame rate of 1?

  1. #1
    Join Date
    Sep 2012
    Posts
    21

    Default Is it possible to record with a framerate of 1?

    Is it possible to record a live stream that has for example a framerate of 15 and record it to a mp4 with a framerate of 1?
    Last edited by rubensd; 06-10-2013 at 02:07 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You can do it with the Wowza Transocder, there are frame_rate and fps settings in the MainConcept encoder params.

    INFO server comment - # long: vui parameters: timing info use together with time_scale
    INFO server comment - mainconcept.num_units_in_tick: 900900
    
    INFO server comment - # long: vui parameters: timing info use together with num_units_in_tick (fps = time_scale/num_units_in_tick)
    INFO server comment - mainconcept.time_scale: 27000000
    
    INFO server comment - # double: frame_rate
    INFO server comment - mainconcept.frame_rate: 15.0
    It seemed to work with just the frame_rate param in my test, but following the comments I also added time_scale and units_in_tick, and set time_scale to 900900. I tested with the 160p encode in the transrate.xml template.
    					<Parameters>
    					
    					
    						<Parameter>
    							<Name>mainconcept.frame_rate</Name>
    							<Value>1</Value>
    							<Type>Double</Type>
    						</Parameter>
    						
    					
    						<Parameter>
    							<Name>mainconcept.time_scale</Name>
    							<Value>900900</Value>
    							<Type>Long</Type>
    						</Parameter>
    						
    						<Parameter>
    							<Name>mainconcept.num_units_in_tick</Name>
    							<Value>900900</Value>
    							<Type>Long</Type>
    						</Parameter>						
    					
    					</Parameters>
    Then I see this in the logs:
    INFO transcoder encoder-video-start Stream1 {name:"160p", bitrate:200000, codec:H264, profile:Baseline, level:2.1, frameSize:282x160, displaySize:282x160, frameRate:1.0}
    The 360p remains 24 in my test:
    INFO transcoder encoder-video-start Stream1 {name:"360p", bitrate:850000, codec:H264, profile:Main, level:3.1, frameSize:636x360, displaySize:636x360, frameRate:24.0}
    ffprobe shows the same.

    Richard
    Last edited by rrlanham; 06-10-2013 at 07:55 AM.

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Actually, these do work. My transcode application was pointing to a different template. See edits in previous post.

    Richard

Similar Threads

  1. Replies: 3
    Last Post: 12-05-2013, 05:32 PM
  2. Transcode Frame Rate
    By Moresheth in forum AddOn: Transcoder
    Replies: 2
    Last Post: 05-01-2013, 12:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •