Results 1 to 5 of 5

Thread: Load testing tool dosen't stop playing.

  1. #1
    Join Date
    Mar 2013
    Posts
    5

    Default Load testing tool dosen't stop playing.

    Hi.

    I ran the load testing tool, but it did not work as expected.

    I set the doRepeat parameter false.
    I ran "performance.bat vod", then NetStream.Play.Start displayed.
    But dispalyed following message endlessly, not stopping to play.

    INFO server comment - Status running:1 currBehind:0

    I expected it to stop when playing time has elapsed.
    Why dose it continuing to recieve data endlessly?
    I changed the doRepeat parameter true but nothing chenged.

    And I want to know the details of the output. is any reference about this tool.

    For instance, what does "totalBytes: 0" means?

    Regards,
    k.inami

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    When you run "performance.bat vod" the tool will replicate the number of RTMP clients that have been configured.
    To stop the performance test press <Ctrl>+<C> and the performance test will stop.

    This tool is very basic and you will have to calculate the bandwidth being used by yourself either by [Connection Counts] x [Stream Bitrate] or sending the traffic through a router which will record the traffic for you.

    Jason

  3. #3
    Join Date
    Mar 2013
    Posts
    5

    Default

    Hi,

    I started only worker to play 128k audio stream.
    I use Windws 2008 server as client to use load testing tool. And I saw on resorce monitor, java.exe recieved 75byte/sec.
    I think load testing tool continued to play, so stream did not stop.
    When I executed another program to play, It recieved 18KB/sec.
    Is there any setting required?

    Regards,
    k.inami

  4. #4
    Join Date
    Mar 2013
    Posts
    5

    Default

    I fix it myself.

    StreamName needs mp4:, but I wrote only file basename on Test.xml file.

    Wrong:
    <Property>
    <Name>streamName</Name>
    <Value>music</Value>
    </Property>

    Correct:
    <Property>
    <Name>streamName</Name>
    <Value>mp4:music</Value>
    </Property>


    Thanks.
    K.inami

  5. #5
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    Glad you got this working and thanks for the update.

    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •