Results 1 to 8 of 8

Thread: EZDRM, unable to package different file formats, and unable to play packaged ones

  1. #1

    Smile EZDRM, unable to package different file formats, and unable to play packaged ones

    Hello, I am trying to set up streaming with EZDRM, downloaded playready packager, but providing the input directory, having multiple files with multiple formats, it only packages the .wmv file, and doesn't package .mp4, .flv, .avi...etc.

    Also the packaged .wmv file, doesn't run on the wowza stream, I think because the server itself doesn't support that file format.

    Thank you.

  2. #2

    Default

    Did you setup your account on the EZDRM side? There are two guides to follow, the ezdrm guide and the Wowza guide.

    Wowza guide:
    http://www.wowza.com/forums/content....-PlayReady-DRM

    This is theirs.
    https://www.ezdrm.com/html/Members/D...ilverlight.asp

    The most important thing in the ezdrm guide is to skip #3 and #4, ignore those steps completely. Step #5 shows an IFrame pre-populated with your info which is not an example, it will work as shown on that page for your account. You just open a web page with that IFrame for a second, then navigate to the Silverlight example player. I just added a meta redirect to the page with the IFrame (this is a stub for your authentication process). You have to make sure the IFrame page is served from the domain/IP you set in ezdrm, and that the player is servved from that domain, and the Manifest URL uses that domain or IP.

    And you have to be sure the username and password you set in the Application.xml matches the account.

    If you don't have it working to send:

    1) Send the email you got from ezdrm with your credentials
    2) send screen shots of your account settings

    To support@wowza.com

    Salvaodre
    Last edited by salvadore; 07-08-2013 at 05:41 AM.

  3. #3

    Default

    Ok thanks greatly, I check the steps again.

  4. #4

    Default

    Ok I actually was doing it wrong, as you said I shouldn't have done steps #3 and #4, so anyways, and I get the URL:

    <iframe src="Http://playready.ezdrm.com/SiteAuth.aspx?SiteID=MY_KEY&p1=5&p2=%20&p3=" frameborder="0" width="1%" height="1%">
    <iframe>

    but When I enter it in browser, I get:

    XML Parsing Error: no element found
    Location: http://playready.ezdrm.com/SiteAuth....&p1=30&p2=&p3=
    Line Number 1, Column 1

    Does it work locally on my PC or should I upload my server online? I have my localhost and loopback IP address configured on my EZDRM site...

  5. #5

    Default

    You need to load the IFrame for a second then redirect to the player.

    you can use meta refresh in the html/head tag.

    <head>      
        <title></title>      
        <meta http-equiv="refresh" content="1;URL=[wowza-dir]/examples/VideoOnDemandStreaming/SilverlightPlayer/player.html" />    
      </head>
    Salvadore

  6. #6

    Default

    hello, sorry to get back to you again. but I am still getting this error

    XML Parsing Error: no element found
    Location: http://playready.ezdrm.com/SiteAuth....&p1=30&p2=&p3=
    Line Number 1, Column 1

    What is the problem?

    - I updated my accounts on EZDRM site.
    - Made the configurations in the XML file.
    - Added the iframe code to the example player. Even created the new page you gave me the code to, that will redirect you to the player example page.

    and still not working...

    Again, does it work locally? Wowza + player are on my local PC, not online to a real IP nor domain?

  7. #7
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    The IFrame and the meta refresh tag are on one page, the player is on another page that the meta refresh redirects to. Both pages should be served from the domain you have registered with EZDRM. And the stream should be from that domain.

    If that doesn't help, we will have to take a closer look. First, restart Wowza and run another playback test. Then zip up the /conf folder and the current access log showing re-start and playback test.

    Send the email you got from ezdrm with your credentials and screen shots of your account settingso support@wowza.com.

    And send the email you got from ezdrm with your credentials, and send screen shots of your account settings.

    And send both the html pages: 1) IFrame and meta refresh, 2) player page.

    Include a link to this thread for reference.

    Richard

  8. #8

    Default

    Hi there ... I'm trying to test EZDRM and Wowza, and I keep getting error 6002, which as per Microsoft info, means I'm not getting the license. The Manifest seems to have the right info when I pull it with a wget
    So, reviewing whole setup and steps in the guides, I think something might be wrong as per bad interpretation of the instructions
    so, on EZDRM I have the option to set up url where the player is (it doesn't say domain as mentioned here) and IP of the server where the player is ... so, is it domain or url I need to register there ... for instance, if my player is on http://www.mydomain.com/testplayer/player.html .... what should be what I register on EZDRM?
    And then the part that says "stream should be from that domain" ... what does it mean? that the url of the stream needs to be something like "http://wowza.mydomain.com:1935/vod/mp4:sample.mp4/Manifest" ?

    Thanks for any response

Similar Threads

  1. Unable to play 3gp video file using wowza media server 3.1
    By Rajesbx9 in forum Media Players and Devices Discussion
    Replies: 6
    Last Post: 07-26-2013, 05:38 AM
  2. Wowza unable to play RTSP. I have tried everything I've seen.
    By HereWeGo in forum Live Streaming and Encoder Discussion
    Replies: 6
    Last Post: 05-14-2012, 04:06 AM
  3. Replies: 1
    Last Post: 12-24-2011, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •