Results 1 to 6 of 6

Thread: "Ticks" in audio when transcoding G711-A to AAC

  1. #1
    Join Date
    Apr 2010
    Posts
    5

    Post "Ticks" in audio when transcoding G711-A to AAC

    i'm trying to re-stream an RTSP IP camera with video+audio. i configured the camera's audio codec to G711-A since it's supported in the transcoder.
    when i open the RTSP stream directly using VLC, the media information appear as follows:
    Video:
    Codec - H264 - MPEG-4 AVC (part10) (h264)
    Resolution - 704x576
    Frame rate - 120

    Audio:
    Codec - PCM ALAW (alaw)
    Channels - Mono
    Sample Rate: 8000 Hz
    Bits per sample: 16


    when i disable the audio in the camera, i can watch the video smoothly via Wowza (in RTMP).
    when i enable the audio in the device, and load wowza with the default transcoder.xml template i can see the video, hear the sound but with 2 problems:
    1. i constantly hear "Ticks" every few seconds (2/4/7/10).
    2. the video becomes less smooth, begins to stuck a lot.

    any suggestions?
    roee.
    Last edited by roee_k; 07-15-2013 at 02:51 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    roee,

    The most recent patch (6) includes g.711 improvements. Please apply this patch and see if it helps.

    http://www.wowza.com/forums/content....lopment-Builds

    Richard

  3. #3
    Join Date
    Apr 2010
    Posts
    5

    Default

    checked.
    still the same.
    is there any useful debugging for that?
    i can share a link for that stream if it helps

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Are you testing playback of a transcoded stream (e.g., myStream_360p), or the source?

    Are you testing with a developer license? In that case, there is an audio watermark, not sure if it a tick every few seconds.

    Richard

  5. #5
    Join Date
    Apr 2010
    Posts
    5

    Default

    testing the source, and with developer license.
    if i use "free-trial" license, i would still have those watermarks?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The 30 day Trial license does not have the watermark.

    Richard

Similar Threads

  1. Detect "white noise" in aac live stream
    By joesmith in forum General Forum
    Replies: 1
    Last Post: 01-18-2012, 07:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •