Results 1 to 5 of 5

Thread: Apple HTTP Live Streaming Path Problem

  1. #1
    Join Date
    Jul 2013
    Posts
    15

    Default Apple HTTP Live Streaming Path Problem

    Greetings!!!

    I am following the example given in the tutorial for Apple HTTP Live Streaming (HLS - iPhone, iPad, iPod touch) http://www.wowza.com/forums/content.php?217#quickTest

    In the mentioned example url for stream playback is from the myapplication directory (http://mycompany.com:1935/myapplicat.../playlist.m3u8) which is mentioned in <StorageDir>, and the videos are at the root of <StorageDir>

    In my case <StorageDir>D:\MyContent\</StorageDir> and D:\MyContent\ is only the root, it is also having D:\MyContent\ABC, D:\MyContent\XYZ and so on.....

    Now i am trying to give the URL stream as http://mycompany.com:1935/myapplicat.../playlist.m3u8, which is not working


    please suggest

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    You may want to include the application instance i.e.

    http://mycompany.com:1935/myapplicat.../playlist.m3u8

  3. #3
    Join Date
    Jul 2013
    Posts
    15

    Default

    hi Matt !!

    My application is having nested folder, in the storagedir i gave the root from where my nest of folder starts (D:\content)

    my video file exist at the location d:\content\abc\123\video\mp4\video1.mp4

    I am trying to play the stream with the following address:
    ServerIP/myapplication/mp4:/abc/123/video/mp4/video1.mp4/playlist.m3u8 (which is not working)


    now please correct me where iam wrong
    Last edited by budhiraja; 07-15-2013 at 05:17 AM.

  4. #4
    Join Date
    Jun 2012
    Posts
    722

    Default

    Did you try without the first "/", like this?
    wowzaIPort/app/_definst_/mp4:abc/123/video/mp4/video1.mp4/playlist.m3u8

    Zoran
    Last edited by zoran_u; 07-16-2013 at 06:37 AM.

  5. #5
    Join Date
    Jul 2013
    Posts
    15

    Default

    thx Zoran

    I have tried using both the options with and without "/", no result, cannot play the stream
    I have tried this with the default VOD applicationa as well with my defined myapplication

    As mentioned by you in (wowzaIPort/app/_definst_/mp4:abc/123/video/mp4/video1.mp4/playlist.m3u8), do i need to give _definst_ after the application name and then mention the encoder, thereafter the path of the video file, for instance my application name is myapplication, thn URL should be: wowzaIPort/myapplication/_definst_/mp4:abc/123/video/mp4/video1.mp4/playlist.m3u8

    please suggest

Similar Threads

  1. Replies: 1
    Last Post: 03-13-2012, 04:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •