Results 1 to 3 of 3

Thread: Unable to mount S3 Bucket using FUSE s3fs

  1. #1
    Join Date
    Dec 2012
    Posts
    9

    Default Unable to mount S3 Bucket using FUSE s3fs

    I have an S3 bucket which I'm trying to mount as a files system in my EC2 instance however when I do, the command works and no errors are returned but I do not see any of my directories or files listed in the file location.

    I'm following the guide here http://www.wowza.com/forums/content.php?72 and believe I have followed it correctly and I'm sure the Access Key and Secret Key are correct as they are the ones I use to stream using the MediaCache plugin. Is there a step I am missing?

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    That sounds correct. When you do a ls -al on the /mnt/s3 it returns nothing? If you list all your mounted drives, does it show up as mounted?

  3. #3
    Join Date
    Dec 2012
    Posts
    9

    Default

    Hi Matt, yes that is correct, the device shows as mounted but empty (see below)

    Filesystem            Size  Used Avail Use% Mounted on
    /dev/xvda1            9.9G  1.4G  8.1G  14% /
    tmpfs                 829M     0  829M   0% /dev/shm
    /dev/xvdb             147G  241M  140G   1% /media/ephemeral0
    s3fs                  256T     0  256T   0% /mnt/s3
    [root@ip-172-31-14-23 /]# ls -al /mnt/s3/
    total 0
    [root@ip-172-31-14-23 /]#

Similar Threads

  1. Unable to mount S3 Bucket using FUSE s3fs
    By SimonShapcott in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 07-19-2013, 07:33 AM
  2. Replies: 1
    Last Post: 04-02-2013, 02:36 PM
  3. cannot mount s3fs
    By ergomatic in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 7
    Last Post: 04-01-2012, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •