Results 1 to 4 of 4

Thread: Stream name confusion on transcode

  1. #1

    Default Stream name confusion on transcode

    I would like to transcode a live stream from MPEG-4 Layer 2 to H.264. My content dir has a file called "mpeg4.stream". Does this mean that I should use a URL like... "rtsp://<ip>:1935/live2/mpeg4.stream_240p" when using VLC? The application live2 is configured for transcode using the default template.

    I am using application live to restream H.264 and the following works for camera.stream... "rtsp:<ip>:1936/live/camera.stream"

    I'm just not sure if the transcode is actually working because no matter how I format the stream name I get nothing.

    John
    Last edited by fly135; 07-19-2013 at 11:54 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    John,

    The form is right, but in the default transcode.xml template the 240p /Encode block is not enabled (Enabled = "false"). The 360p stream is enabled, so try that.

    rtsp://<ip>:1935/live2/mpeg4.stream_360p

    Otherwise, take a look at the access log (I open them in Excel). Find the publish event for the stream you are transcoding. See if the stream starts successfully, and if the Transcoder is started.

    Richard

  3. #3

    Default

    In the transcode template it shows the <StreamName> as mp4:$<SourceStreamName>_240p

    Does the mp4: affect anything else? Or is it just internal to the template file?

    John

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    For live playback it is optional, but if you record the stream Wowza will record to a .mp4 container if the stream name has mp4: prefix. Otherwise Wowza records to .flv container

    Richard

Similar Threads

  1. Java confusion
    By kleelof in forum General Forum
    Replies: 3
    Last Post: 05-31-2012, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •