Results 1 to 6 of 6

Thread: Error: Over flush iteration limit

  1. #1
    Join Date
    Apr 2013

    Default Error: Over flush iteration limit

    Dear Support team

    I just run live streaming application for a while, It seem to be that it work properly for a long time and get plenty of error for a whole day.

    LiveStreamPacketizerSanJose.handleHolder[abc/_definst_/]: Over flush iteration limit.
    LiveStreamPacketizerCupertino.handleHolder[abc/_definst_/]: Over flush iteration limit.

    How does it come and how can I fix it?

    Thank you

  2. #2
    Join Date
    May 2013


    Hello Mark,

    What version of Wowza are you on? We had a patch/release that improved the packetization processes that seemingly solved this problem. Check out our upgrade guide to get the latest:

    Wowza Media Server Upgrade Guide

  3. #3
    Join Date
    Apr 2013


    I use Wowza 3.5.2, I run 5 application in the same time but I didn't know why the log error come from just one application.
    However I will try upgrade the version to 3.6

  4. #4


    hi marknm12,
    what type of encoder you use ? I have the same problem when using FMLE and do not restart encoder for 7-8 days continuum .
    please keep in mind that FMLE is certified for running continuous for 7 days .
    I have solved with schedule automatic maintenance restart on FMLE (from command line or XML)


  5. #5


    We have the same problem periodically.
    It was happened with 3.5.2-build3747 and 3.6.2-build5334 also.

    We use custom proprietary encoder which produces MPEG-TS with several video and audio streams.

    I am having this problem now.
    I see a strange answers on every request to playlist.m3u8.
    Interval between requests is several seconds.

    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=1,CODECS="avc1.66.13, mp4a.40.2",RESOLUTION=320x240

    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=1,CODECS="avc1.66.13, mp4a.40.2",RESOLUTION=320x240

    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=1,CODECS="avc1.66.13, mp4a.40.2",RESOLUTION=320x240

  6. #6



    There were 2 fixes for this problem. The first main fix was in 3.5.2 patch 8 and fixed most cases of the problem. A second fix in 3.6.2 patch 6 fixed some other edge cases.

    Please update to the latest patch version (currently 3.6.2 patch 9) from here,

    The wXXXXXXXX in the url is the Wowza session id and is a new format that was introduced in 3.6.2 to remove the need for a query string variable that was causing problems with some players.


Similar Threads

  1. java.util.ConcurrentModificationException during client.getPlayStreams() iteration
    By Gpolox in forum Server-side Modules and Code Samples Discussion
    Replies: 10
    Last Post: 05-30-2014, 12:08 AM
  2. where did flush interval goes ?
    By gentmat in forum Performance and Tuning
    Replies: 4
    Last Post: 02-16-2014, 10:41 AM
  3. tons of warnings "Over flush iteration limit"
    By Luca066 in forum General Forum
    Replies: 23
    Last Post: 05-04-2013, 05:27 PM
  4. overflow iteration limt
    By Robins in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-02-2013, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts