Results 1 to 5 of 5

Thread: Request timeout when streaming with nDVR

  1. Default Request timeout when streaming with nDVR

    Starting the stream without nDVR works fine (http://*.*.*.*:1935/live/myStream/manifest.f4m) but with nDVR (http://*.*.*.*:1935/live/myStream/manifest.f4m?DVR) I get an error message in the log:
    HTTPStreamerAdapterSanJoseStreamer.service: Request timeout: 8000
    Can anyone tell me what's wrong?
    Here's the Application.xml
    <?xml version="1.0" encoding="UTF-8" standalone="no"?><Root>
    	<Application>
    		<Connections>
    			<AutoAccept>true</AutoAccept>
    			<AllowDomains/>
    		</Connections>
    		<Streams>
    			<StreamType>live</StreamType>
    			<StorageDir>${com.wowza.wms.context.VHostConfigHome}/content</StorageDir>
    			<KeyDir>${com.wowza.wms.context.VHostConfigHome}/keys</KeyDir>
    			<LiveStreamPacketizers>cupertinostreamingpacketizer,smoothstreamingpacketizer,sanjosestreamingpacketizer,dvrstreamingpacketizer</LiveStreamPacketizers>
    			<Properties>
    				<Property>
    					<Name>versionFile</Name>
    					<Value>false</Value>
    					<Type>Boolean</Type>
    				</Property>
    				<Property>
    					<Name>appendFile</Name>
    					<Value>true</Value>
    					<Type>Boolean</Type>
    				</Property>
    			</Properties>
    		</Streams>
    		<Transcoder>
    			<LiveStreamTranscoder/>
    			<Templates>${SourceStreamName}.xml,transrate.xml</Templates>
    			<ProfileDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/profiles</ProfileDir>
    			<TemplateDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/templates</TemplateDir>
    			<Properties>
    			</Properties>
    		</Transcoder>
    		<DVR>
    			<Recorders>dvrrecorder</Recorders>
    			<Store>dvrfilestorage</Store>
    			<WindowDuration>0</WindowDuration>
    			<StorageDir>${com.wowza.wms.context.VHostConfigHome}/dvr</StorageDir>
    			<ArchiveStrategy>append</ArchiveStrategy>
    		</DVR>
    		<TimedText>
    			<VODTimedTextProviders>vodcaptionprovidermp4_3gpp</VODTimedTextProviders>
    			<Properties>
    			</Properties>		
    		</TimedText>		
    		<HTTPStreamers>cupertinostreaming,smoothstreaming,sanjosestreaming</HTTPStreamers>
    		<SharedObjects>
    			<StorageDir/>
    		</SharedObjects>
    		<Client>
    			<IdleFrequency>-1</IdleFrequency>
    			<Access>
    				<StreamReadAccess>*</StreamReadAccess>
    				<StreamWriteAccess>*</StreamWriteAccess>
    				<StreamAudioSampleAccess/>
    				<StreamVideoSampleAccess/>
    				<SharedObjectReadAccess>*</SharedObjectReadAccess>
    				<SharedObjectWriteAccess>*</SharedObjectWriteAccess>
    			</Access>
    		</Client>
    		<RTP>
    			<Authentication>
    				<PublishMethod>digest</PublishMethod>
    				<PlayMethod>none</PlayMethod>
    			</Authentication>
    			<AVSyncMethod>senderreport</AVSyncMethod>
    			<MaxRTCPWaitTime>12000</MaxRTCPWaitTime>
    			<IdleFrequency>75</IdleFrequency>
    			<RTSPSessionTimeout>90000</RTSPSessionTimeout>
    			<RTSPMaximumPendingWriteBytes>0</RTSPMaximumPendingWriteBytes>
    			<RTSPBindIpAddress/>
    			<RTSPConnectionIpAddress>0.0.0.0</RTSPConnectionIpAddress>
    			<RTSPOriginIpAddress>127.0.0.1</RTSPOriginIpAddress>
    			<IncomingDatagramPortRanges>*</IncomingDatagramPortRanges>
    			<!-- Properties defined here will override any properties defined in conf/RTP.xml for any depacketizers loaded by this application -->
    			<Properties>
    			</Properties>
    		</RTP>
    		<MediaCaster>
    			<RTP>
    				<RTSP>
    					<RTPTransportMode>interleave</RTPTransportMode>
    				</RTSP>
    			</RTP>
    			<Properties>
    			</Properties>
    		</MediaCaster>
    		<MediaReader>
    			<Properties>
    			</Properties>
    		</MediaReader>
    		<MediaWriter>
    			<Properties>
    			</Properties>
    		</MediaWriter>
    		<LiveStreamPacketizer>
    			<Properties>
    			</Properties>
    		</LiveStreamPacketizer>
    		<HTTPStreamer>
    			<Properties>
    			</Properties>
    		</HTTPStreamer>
    		<Repeater>
    			<OriginURL/>
    			<QueryString/>
    		</Repeater> 
    		<Modules>
    			<Module>
    				<Name>base</Name>
    				<Description>Base</Description>
    				<Class>com.wowza.wms.module.ModuleCore</Class>
    			</Module>
    			<Module>
    				<Name>properties</Name>
    				<Description>Properties</Description>
    				<Class>com.wowza.wms.module.ModuleProperties</Class>
    			</Module>
    			<Module>
    				<Name>logging</Name>
    				<Description>Client Logging</Description>
    				<Class>com.wowza.wms.module.ModuleClientLogging</Class>
    			</Module>
    			<Module>
    				<Name>flvplayback</Name>
    				<Description>FLVPlayback</Description>
    				<Class>com.wowza.wms.module.ModuleFLVPlayback</Class>
    			</Module>
    			<Module>
    				<Name>Wmsauth</Name>
    				<Description>Wmsauth</Description>
    				<Class>com.wmspanel.Wmsauth</Class>
    			</Module>
    			<Module>
    				<Name>streamcontroller></Name>
    				<Description>ModuleStreamControl</Description>
    				<Class>com.wowza.wms.plugin.collection.module.ModuleStreamControl</Class>
    			</Module>
    			<Module>
    				<Name>ModuleMediaWriterFileMover</Name>
    				<Description>ModuleMediaWriterFileMover</Description>
    				<Class>com.wowza.wms.module.ModuleMediaWriterFileMover</Class>
    			</Module>
    		</Modules>
    		<Properties>
    		</Properties>
    	</Application>
    </Root>

  2. #2

    Default

    Hi, what version of Wowza are you running?

    Can you share your video and audio codec info?
    Are there any other corresponding log messages?

    Salvadore

  3. Default

    Wowza Media Server 3 Monthly Edition 3.6.0 build5155

    Video: h.264
    Audio: AAC

    No other exceptional log messages than the one posted earlier (Request timeout)

  4. #4

    Default

    You can update Wowza with the latest patch and see if that helps.
    Software Updates

    Salvadore

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    To get to the latest version if you are below 3.6.2, first apply this patch then, over that, the latest development build

    That will bring you to Wowza version 3.6.2.10

    Also, for anything involving Flash HTTP (sanjose) it is best to be using a player that is using OSMF 2 (rather than OSMF 1.6). The Wowza Flash HTTP players or use this OSMF 2 configurator

    Richard

Similar Threads

  1. Replies: 3
    Last Post: 06-04-2014, 03:31 PM
  2. setPlaylistStart + setPlaylistEnd=Request timeout
    By pidboretskyy in forum AddOn: Wowza nDVR
    Replies: 0
    Last Post: 04-14-2012, 01:44 PM
  3. HTTPStreamerAdapterCupertinoStreamer.service: Request timeout: 8000
    By ejohn240 in forum Video On Demand Streaming Discussion
    Replies: 0
    Last Post: 03-16-2012, 07:50 AM
  4. Wowza nDVR Playlist Request API
    By divyabhargov in forum AddOn: Wowza nDVR
    Replies: 8
    Last Post: 11-23-2011, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •