Results 1 to 3 of 3

Thread: how to prevent FFMPEG to stream to wowza

  1. #1

    Default how to prevent FFMPEG to stream to wowza

    I see we can use the following command to stream to Wowza using FFMPEG

    /root/ffmpeg -i "abc.f4v" -re -isync -vcodec copy -acodec copy -f flv "rtmp://IP/streamname flashver=FME/3.0\20(compatible;\20FMSc/1.0)"

    Is there a way to configure wowza to stop FFMPEG to stream to wowza?


  2. #2


    You could use this example as a starting place to prevent FFMPEG to stream to Wowza based on the user agent:
    How to block a duplicate publish stream

    This example shows how to override publish but would need to be tweaked to suite your needs.

    Also there is no way to prevent a user of FFMPEG from setting the user agent to whatever they choose.

    You can set up user authentication to control who is allowed to publish a stream ModuleRTMPAuthenticate

    Last edited by salvadore; 08-26-2013 at 08:14 AM.

  3. #3


    In general ffmpeg internal behavior and <your_publisher> behavior may be different when working with wowza, so it should be possible to write module to detect that difference.
    We can talk more via email: rshmelev [at] gmail {dot} com

Similar Threads

  1. Prevent hotlinking to rtmp stream?
    By BrianPss in forum General Forum
    Replies: 3
    Last Post: 03-05-2014, 05:23 PM
  2. Using FFmpeg with an RTMP Wowza stream on an app instance as the source
    By Benny Veo in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 08-21-2013, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts