Results 1 to 4 of 4

Thread: No audio when streaming from IP camera (H.264 and G.711)

  1. #1
    Join Date
    Jun 2012
    Posts
    5

    Default No audio when streaming from IP camera (H.264 and G.711)

    Hi,

    I have an IP camera broadcasting in RTSP to the Wowza Media Server 3. I have transcoder Add-On.

    The feed is coming as H.264 and the audio is G.711

    No audio is heard.

    Extracted from access.log below.


    Line 1384: 2013-08-24 08:12:08 BST comment server WARN 200 - Failed to find an appropriate depacketizer for this track (PCMU) _defaultVHost_ live _definst_ 63034.854 - 80 null 127.0.0.1 rtsp - known 1572331461 0 0 - - - - - - - - - - - - - null -
    Line 1393: 2013-08-24 08:12:08 BST comment server WARN 200 - Failed to find an appropriate depacketizer for this track (PCMU) _defaultVHost_ live _definst_ 63035.119 - 80 null 127.0.0.1 rtsp - known 1028848259 0 0 - - - - - - - - - - - - - null -
    Line 1564: 2013-08-24 08:12:59 BST comment server WARN 200 - Failed to find an appropriate depacketizer for this track (PCMU) _defaultVHost_ live _definst_ 63086.22 - 80 null 127.0.0.1 rtsp - known 2088341818 0 0 - - - - - - - - - - - - - null -
    Line 1572: 2013-08-24 08:12:59 BST comment server WARN 200 - Failed to find an appropriate depacketizer for this tr

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What playback client are you using? G.711 should work in a Flash RTMP or Flash HTTP client, but won't work in RTSP, iOS or Silverlight clients at present. Support for RTSP clients should be added sometime soon, though I don't have an exact time frame.

    Richard

  3. #3
    Join Date
    Jun 2012
    Posts
    5

    Default

    We are using the native IOS player at the moment. Is there a way to convert the audio codec to AAC using the transcode.xml? Here is an extract from transcode.xml. Is this supposed to convert the G.711 codec to AAC?

    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>96000</Bitrate>
    <Parameters>
    </Parameters>
    </Audio>

    I also like to confirm with you the correct location of the transcode.xml file. Should it be in the templates folder
    C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.1.2\transcoder\templates

    or a level above at
    C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.1.2\transcoder

    Regards,
    Edwin

  4. #4

    Default

    Hi Edwin,

    Yes, you can re-encode this audio format using the Wowza Transcoder.

    In your transcoder/templates folder, you should see an audioonly template. It is best to use this one if you only need to transcode the audio.

    Once you have selected a template, you set the name in your Application.xml in the Transcoder/Templates setting.

    The folder that the templates are in can also be set in the Application.xml in the Transcoder/TemplateDir setting. The default is the transcoder/templates folder.

    Roger.

Similar Threads

  1. Ip camera video delay after G.711 transcoding
    By cruisher in forum AddOn: Transcoder
    Replies: 8
    Last Post: 03-29-2012, 05:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •