Results 1 to 7 of 7

Thread: NIVIDIA K4000 performance

  1. #1

    Question NIVIDIA K4000 performance

    I have installed NIVIDIA K4000 Video Card with my CentOS release 6.4 - 64 bit with 16 GB RAM and (8 2.50GHz processors).

    Wowza is also recognizing the Video Card.. as in my log I am seeing...

    2013-08-30 14:20:26 AST comment server INFO 200 - JNI:NVidiaCUDAUtils.logCUDAGPUInfo[_defaultVHost_:liveorigin/_definst_/channel9.stream]: GPU[0]: name:"Quadro K4000" version:3.0 driver:5050 memory:3071MB processors:4 cores:768 clockRate:810MHz NVENC:yes

    I am transcoding incoming MPEG-2 stream to H.264 (1 mbps). But after installing the Video Card.. I am not seeing any performance improvement.

    What are the checklist to ensure the Video Card Acceleration is done properly.

    Note: I update all packages before setting up the Video Card.


    Thanks,
    BIrendra

  2. #2

    Default

    Hi,

    I had set transcoder type to default. That is why the Video acceleration was not working properly.
    I set it to NVENC, now its working.

    However I am facing another issue now, The stream is getting pixelated. When I disable the Video Card, it plays fine.

    Here is the video sample, how it looks

    https://www.youtube.com/watch?v=BrSh...e_gdata_player

    Thanks,
    Birendra
    Last edited by dhamibirendra; 08-31-2013 at 10:10 AM. Reason: Video sample Link added

  3. #3

    Default

    Hi anyone..??

    Thanks
    Birendra

  4. #4
    Join Date
    Jul 2012
    Posts
    299

    Default

    Birendra,

    It sounds like your GPU is installed and running correctly. What metric are you using to determine good/bad performance? An external graphics card will migrate the transcoder resource load from the CPU to the graphics card, however, it won't necessarily visually improve the quality (although some nuances exist between the CPU and external graphics card workflows).

    If you would like us to take a closer look at your configuration, send an email to support@wowza.com with a reference to this post and include a copy of your [install-dir]/conf, /logs and /transcoder folders as a .zip file (or other archive) so I can take a closer look at your configuration and server activity.

    -Tim

  5. #5

    Default

    Hi Tim,

    Thanks for the reply... The pixelating issue is somewhat under control. I increased the bit-rate and the video quality improved to some extend.
    But I am seeing a splash in between every few seconds. By splash I mean it looks like.. someone refreshing the screen.

    Birendra

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    ref ticket #65599

  7. Default

    Hi
    how many output channel can u transcode by this hardware? it is very interesting to know any change to performance?

    Quote Originally Posted by dhamibirendra View Post
    I have installed NIVIDIA K4000 Video Card with my CentOS release 6.4 - 64 bit with 16 GB RAM and (8 2.50GHz processors).

    Wowza is also recognizing the Video Card.. as in my log I am seeing...

    2013-08-30 14:20:26 AST comment server INFO 200 - JNI:NVidiaCUDAUtils.logCUDAGPUInfo[_defaultVHost_:liveorigin/_definst_/channel9.stream]: GPU[0]: name:"Quadro K4000" version:3.0 driver:5050 memory:3071MB processors:4 cores:768 clockRate:810MHz NVENC:yes

    I am transcoding incoming MPEG-2 stream to H.264 (1 mbps). But after installing the Video Card.. I am not seeing any performance improvement.

    What are the checklist to ensure the Video Card Acceleration is done properly.

    Note: I update all packages before setting up the Video Card.


    Thanks,
    BIrendra

Similar Threads

  1. Replies: 5
    Last Post: 11-03-2014, 10:45 AM
  2. About Performance... is this enough?
    By tsioukas in forum Performance Tuning Discussion
    Replies: 1
    Last Post: 12-28-2011, 06:17 PM
  3. Performance
    By TI3GIB in forum AddOn: Transcoder
    Replies: 3
    Last Post: 10-13-2011, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •