Results 1 to 6 of 6

Thread: Transrate fail if mute the source and set audio to pass-thru

  1. #1

    Default MediaList fail if mute the source and set audio to pass-thru

    I found if I set the transrate.xml /Encode /Audio /Codec to PassThru and disable the upstream's audio channel, the MediaList would fail.
    http://[wowz-ip:port]/[appName]/[appInstanceName]/ngrp:[StreamGroupName]/jwplayer.smil
    It could work to set the /Encode /Audio /Codec to Disable in this case, however, the publisher is possible to switch the microphone on/off during the streaming and therefore audio channel is possible to exist or not dynamically. Any suggestion to handle this situation?

    Thank your help
    Last edited by andy_c; 09-04-2013 at 12:02 AM.

  2. #2

    Default

    Hi Andy,

    Can you please run some tests that show what you are describing and then zip up your logs, conf & transcoder templates folders and send them to support@wowza.com along with a description and a link to this thread.
    In the tests, please make sure that the cupertinostreamingpacketizer is enabled so that we can see what is coming in and what is getting transcoded.

    Roger.

  3. #3

    Default

    Attach the logs
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.905	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.validateMembers[_defaultVHost_:liverepeater/_definst_/abc/mystream]: StreamNameGroup[source] audio codec is not valid for name group: UNKNOWN[-1] (unknown)
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.906	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.validateMembers[_defaultVHost_:liverepeater/_definst_/abc/mystream]: StreamNameGroup[360p] audio codec is not valid for name group: UNKNOWN[-1] (unknown)
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.906	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.validateMembers[_defaultVHost_:liverepeater/_definst_/abc/mystream]: StreamNameGroup[160p] audio codec is not valid for name group: UNKNOWN[-1] (unknown)
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.906	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.addInternal[_defaultVHost_:liverepeater/_definst_/abc/mystream]: Name group was not added, it is empty: all
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.907	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.validateMembers[_defaultVHost_:liverepeater/_definst_/abc/mystream]: StreamNameGroup[360p] audio codec is not valid for name group: UNKNOWN[-1] (unknown)
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.907	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.validateMembers[_defaultVHost_:liverepeater/_definst_/abc/mystream]: StreamNameGroup[160p] audio codec is not valid for name group: UNKNOWN[-1] (unknown)
    WARN	server	comment	2013-09-05	17:56:02	-	-	-	-	-	52.907	-	-	-	-	-	-	-	-	TranscoderStreamNameGroup.addInternal[_defaultVHost_:liverepeater/_definst_/abc/mystream]: Name group was not added, it is empty: mobile

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Evidently the source audio is not supported and has to be transcoded. You should not include the source in the StreamNameGroup in that case.

    As Roger suggested, with "cupertinostreamingpacketizer" enabled in the Application.xml /Streams /LiveStreamPacketizers Wowza will report details about the audio encoding for live streams when packetizing begins. This will also report whether the audio (or video) codec is supported or not.

    Richard

  5. #5

    Default

    Hi, I sent a mail includes the logs and other sources, FYI.
    I think the problem is, there is no source audio in this case. The publisher does not attach the audio into stream
                            var h264Settings:H264VideoStreamSettings = new H264VideoStreamSettings();
           		        h264Settings.setProfileLevel( H264Profile.BASELINE, H264Level.LEVEL_3_1 );
    			cam.setQuality(0,100);
    			cam.setMode(640, 360, 15, false);
    			cam.setKeyFrameInterval( 30 );
    			
    			publish_ns.videoStreamSettings = h264Settings;
    			publish_ns.attachCamera(cam);
    			
    			var microphone:Microphone = Microphone.getEnhancedMicrophone();
    			microphone.codec = SoundCodec.SPEEX;
    			microphone.framesPerPacket = 1;
    			microphone.setSilenceLevel(0, 2000);
    			microphone.gain = 50;
    			
    			//publish_ns.attachAudio(microphone);
    			publish_ns.publish("abc/mystream");
    Set the transrate.xml /Encode /Audio /Codec to PassThru then the StreamNameGroup would be fail. Change to Disable it would be workable

  6. #6

    Default

    According to the mail reply (request 66011), it's logged as a bug and waiting for fix.

    Thank your support.

Similar Threads

  1. Transrate audio only
    By thomasba in forum AddOn: Transcoder
    Replies: 1
    Last Post: 01-15-2014, 07:53 AM
  2. Pass-Thru Transrate for Bitrate
    By Moresheth in forum AddOn: Transcoder
    Replies: 3
    Last Post: 09-04-2013, 10:16 PM
  3. AAC Audio only transrate
    By magpar in forum AddOn: Transcoder
    Replies: 1
    Last Post: 01-11-2012, 02:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •