Results 1 to 10 of 10

Thread: Transcoder stream synchronization problem in ABR

  1. #1
    Join Date
    Sep 2013
    Posts
    18

    Default Transcoder stream synchronization problem in ABR

    Hi.

    I'm building a Module that grabs the Wowza Transcoder output streams and republishes them to another server. For this I am using the PushPublish Addon, listening to onPublish and checking if the stream published is a transcoded stream or not. Republish works great and the Transoder creates the streams just fine. Th only problem is that the streams that are republished are not synchronized when playing in adaptative bitrate.

    I'm using QuickSync encoder with a 720p source @1Mbps and encoding to:
    360p @ 700k
    360p @ 500k
    240p @ 300k
    160p @ 100k

    CPU usage is around 20%.

    Thanks for any help you can provide.

    Eduardo

  2. #2

    Default

    What is the other server?
    If it is a Wowza server you should use Live Stream Repeater instead of PushPublish for key frame alignment.

    Salvadore

  3. #3
    Join Date
    Sep 2013
    Posts
    18

    Default

    Hi Salvadore, thanks for the answer. The other server is Adobe Media Server. What should I do?

  4. #4

    Default

    If you open up the PushPublish_3/README.html file and use the "search" function with "adaptive" as the search you will find some settings you will need to configure.

    You will need to set "adaptiveStreaming" to "true" it is set to "false" by default.
    Also "sendOriginalTimecodes" needs to be set to "true" again it is "false" by default.

    You will need to configure the PushPublishMap.txt file with an entry for each rendition of the ABR stream. And you will need to create a .smil file in the[install-dir]/content folder on the remote server.

    This is all documented in more detail in the readme.html file that ships with the PushPublish AddOn.

    Salvadore

  5. #5
    Join Date
    Sep 2013
    Posts
    18

    Default

    Hi Salvadore. Thanks again for your reply. I don't have a README file, maybe i have an old PushPublish version, I downloaded it about a year ago. Is there a newer version?

    Eduardo
    Last edited by roger_l; 09-18-2013 at 04:40 PM.

  6. #6

    Default

    The current version of PushPublish is build 4760.

    To get the latest Push Publishing AddOn, fill out the AddOn Request form. In the form, be sure to select the Click to Request Push Publishing check box.

    Salvadore

  7. #7
    Join Date
    Sep 2013
    Posts
    18

    Default

    Yes, i did fill the request, hope I get an answer soon. Thanks again for all the help.

    Regards
    Eduardo

  8. #8

    Default

    Great. Let us know if you have any other issue, or need assistance with anything else.

    Salvadore

  9. #9
    Join Date
    Sep 2013
    Posts
    18

    Default

    One thing I did not quite understand is why I need a .smil file in the server. Is this for the server that re-publishes or for the target server. Because the target server is AMS and doe not use smil files server-side.

    Regards
    Eduardo

  10. #10

    Default

    Eduardo, you are correct, and I was wrong about the .smil file comment. Please disregard that bit of miss-information.

    You may need to update your Wowza version to run the latest version of PushPublish. I believe the most recent version of PushPublish requires Wowza 3.1.2 or greater.

    Salvadore

Similar Threads

  1. When is Transcoder AddOn Needed (for live ABR streams)?
    By esshiggs in forum Live Streaming and Encoders
    Replies: 5
    Last Post: 03-24-2014, 11:59 PM
  2. Server stream and synchronization issue
    By arseny in forum General Forum
    Replies: 1
    Last Post: 03-13-2013, 02:36 PM
  3. Live stream multicast synchronization
    By jscharlach in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 12-13-2011, 08:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •