Results 1 to 8 of 8

Thread: I have two different HW, one same config files, one cannot ingesting Mpeg2TS

  1. #1

    Default I have two different HW, one same config files, one cannot ingesting Mpeg2TS

    Hi,

    I am unable to find the cause of following behaviour.

    We have two HW, one an old AMD64 with Centos6.4 the other an Intel running Centos6.4. both have the same config files. on the newer Intel machine it returns messages << RTPDePacketizerMPEGTS.init: Drop incomplete video frames>>. it does not even generate chunkfiles (which is logic in a way, as it drop the video). The old AMD64 machine does not display this messages and I am able to see the video in the player.

    I have then copied the whole Wowza folder over to each other machine. the stream does just not want to work on the Intel Platform. all the config and the intel-Wowza folder does work on the AMD machine (copied only the /usr/local/WowzaMediServer-6.3.2)

    Any ideas where the cause could lye? Thanks.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    I think this is most likely a source stream issue, have you tried the source going to the Intel server on the AMD64 server?
    At the bottom of the MPEG-TS based encoder tutorial found below you will see a troubleshooting section which may help resolve the issue.
    MPEG-TS based encoder tutorial

    If the source is streamed to the other server and still doesn't work and the troubleshooting also didn't resolve this issue please let me know.

    Regards
    Jason

  3. #3

    Default

    Quote Originally Posted by JasonH View Post
    Hi,
    I think this is most likely a source stream issue, have you tried the source going to the Intel server on the AMD64 server?
    At the bottom of the MPEG-TS based encoder tutorial found below you will see a troubleshooting section which may help resolve the issue.
    MPEG-TS based encoder tutorial

    If the source is streamed to the other server and still doesn't work and the troubleshooting also didn't resolve this issue please let me know.

    Regards
    Jason
    Hi Jason,

    yes it is the identical source, as the config has been copied from one machine to the other. the source is a Dektec device which stream in a loop. this is our reference stream.

    Thanks,
    J-C

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    If this is the same source it would suggest the second server can not see the MPEG-TS stream or perhaps listening on the wrong interface.
    I would check the firewall and check that all the ports are all open as this sounds more like a network related now that we have ruled out the source as the issue.

    As a test can you pull the source from the server which is handling the stream without issue. This means editing the .stream file you have or creating a new one to pull the source from the other server.
    For example the new .stream file would contain something like:
    rtmp://[Other-server-IP]:1935/live/mpegts.stream

    Jason

  5. #5

    Default

    Quote Originally Posted by JasonH View Post
    Hi,
    If this is the same source it would suggest the second server can not see the MPEG-TS stream or perhaps listening on the wrong interface.
    I would check the firewall and check that all the ports are all open as this sounds more like a network related now that we have ruled out the source as the issue.

    As a test can you pull the source from the server which is handling the stream without issue. This means editing the .stream file you have or creating a new one to pull the source from the other server.
    For example the new .stream file would contain something like:
    rtmp://[Other-server-IP]:1935/live/mpegts.stream

    Jason
    Hi

    I have tested this example to use the output from old wowza server into the ingest of the new wowza. (firewall disabled, NIC is fine, tcpdump OK, pcap dump playable throught tshark with VLC). It does not work. here is some logs.
    Thanks,
    J-C


    2013-09-24 13:57:04 CEST comment server INFO 200 - RTPMediaCaster.create[18326726] - - - 1327.377 - - - - -
    2013-09-24 13:57:04 CEST comment server INFO 200 - RTPMediaCaster.init[18326726] - - - 1327.377 - - - - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPSessionDescriptionDataProviderBasic.rtspSessionTimeout: 15000 - - - 1327.377 - - - - - - - - - - - - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPSessionDescriptionDataProviderBasic.rtspConnectionTimeout: 4000 - - - 1327.378 - - - - - - - - - - - - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server INFO 200 - RTPMediaCaster.Reconnector[18326726:live/_definst_:dektec.stream]: start: 1 - - - 1327.378 - - - - - - - - - - - - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1327.378 - -
    2013-09-24 13:57:04 CEST comment server INFO 200 - HTTPStreamManager.onHTTPRequest: Publish stream successfully started [live/_definst_]: flv:dektec.stream - - - 1327.412 - - - - - - - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server INFO 200 - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: /usr/local/WowzaMediaServer/content/rtmp://138.188.136.91:1935/live/dektec.stream - - - 1327.478 - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server WARN 200 - RTPSessionDescriptionDataProviderBasic.getStreamInfo: SDP file missing: /usr/local/WowzaMediaServer/content/rtmp://138.188.136.91:1935/live/dektec.stream - - - 1327.478 - - - - - - - - - - - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1327.479 - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1327.579 - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1327.679 - -
    2013-09-24 13:57:04 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1327.78 - - -
    2013-09-24 13:57:06 CEST comment server DEBUG 200 - ServerHandler.handleSessionIdle: idleTimeout: 32 - - - 1329.7 - - -
    2013-09-24 13:57:06 CEST comment server DEBUG 200 - ServerHandler.handleSessionIdle: idleTimeout: 32 - - - 1329.84 - - -
    2013-09-24 13:57:06 CEST comment server DEBUG 200 - ServerHandler.handleSessionIdle: idleTimeout: 32 - - - 1329.864 - -
    2013-09-24 13:57:07 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1330.779 - -
    2013-09-24 13:57:07 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1330.879 - -
    2013-09-24 13:57:08 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1330.98 - - -
    2013-09-24 13:57:11 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1333.979 - -
    2013-09-24 13:57:11 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1334.079 - -
    2013-09-24 13:57:11 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1334.18 - - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.179 - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.279 - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.38 - - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.48 - - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.58 - - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.681 - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.781 - -
    2013-09-24 13:57:14 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.881 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1337.982 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.082 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.182 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.283 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.383 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.484 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.584 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1338.684 - -
    2013-09-24 13:57:15 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1338.785 - -
    2013-09-24 13:57:18 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1341.784 - -
    2013-09-24 13:57:18 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1341.884 - -
    2013-09-24 13:57:19 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1341.985 - -
    2013-09-24 13:57:22 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1344.984 - -
    2013-09-24 13:57:22 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1345.084 - -
    2013-09-24 13:57:22 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1345.185 - -
    2013-09-24 13:57:25 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1348.184 - -
    2013-09-24 13:57:25 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 100 - - - 1348.284 - -
    2013-09-24 13:57:25 CEST comment server DEBUG 200 - RTPMediaCaster#Reconnector.run: reconnectDelay: 2999 - - - 1348.385 - -
    2013-09-24 13:57:26 CEST comment server DEBUG 200 - open - - - 1349.411 - - - - - - - -
    2013-09-24 13:57:26 CEST comment server INFO 200 - handshake0: 1537 - - - 1349.411 - - - - - -
    2013-09-24 13:57:26 CEST comment server INFO 200 - RTMPRequestAdapter.service[client.receive]: wowzVersion:0 accept:true

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    WARN 200 - RTPSessionDescriptionDataProviderBasic.getStreamIn fo: SDP file missing: /usr/local/WowzaMediaServer/content/rtmp://138.188.136.91:1935/live/dektec.stream
    Are you starting the stream with MediaCaster type "rtp" instead of "liverepeater" using StreamManager or /conf/StartUpStreams.xml ? Use MediaCaster "liverepeater"

    Richard

  7. #7

    Default

    Hi Richard,

    thanks for your post. The application was resolving the IP onto the wrong NIC. "Drop incomplete video frames" can also mean that there is no stream at all at the input of the host.

    Ragards,
    J-C

  8. #8
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    Thanks for the update.
    I'm glad you have resolved the issue, that's great news.

    Regards
    Jason

Similar Threads

  1. Ingesting YouTube stream
    By Lucas0511 in forum Wowza Transcoder
    Replies: 1
    Last Post: 08-25-2014, 05:35 AM
  2. Ingesting live stream from cdn
    By viingmediaco in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 03-17-2014, 06:36 AM
  3. Plug-in development to serve VoD files MPEG2TS over UDP/RTP/RTSP to IPTV STB
    By jernandez in forum Wowza Streaming Engine functionality
    Replies: 1
    Last Post: 07-05-2013, 03:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •