Results 1 to 3 of 3

Thread: Flowplayer event with nDVR

  1. #1
    Join Date
    Jan 2012
    Posts
    27

    Default Flowplayer event with nDVR

    I'm using Wowza 3.5.2 with nDVR and trying to get flowplayer flash to work. We are seeing a number of issues:

    1. The onStart event never gets fired, doesn't matter if autoPlay is true or false.
    2. When starting the player the twirling buffering circle is displayed all the time, not just when buffering. If I pause and resume it goes away.
    3. After pausing the player I get an onPause event but when resume play I do not get a onResume event.


    Here's the code I'm testing with:


        flowplayer("httpstreaming", "js/flowplayer/flowplayer-3.2.16.swf", {
            plugins: {
                f4m: {
                    url: "js/flowplayer/flowplayer.f4m-3.2.9.swf",
                },  
                httpstreaming: {
                    url: "js/flowplayer/flowplayer.httpstreaming-3.2.10.swf"
                },  
            },
            clip: {
                url: 'http://mywowzaserver:1935/dvr/appinstance/mycamera.stream/manifest.f4m?DVR',
                urlResolvers: ['f4m'],
                provider: 'httpstreaming',
                autoPlay: true,
    
                onStart: function() { alert("onStart"); },
                onPause: function() { alert("onPause"); },
                onResume: function() { alert("onResume"); }
            }
        })

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    These events may be associated with RTMP playback only. I would also ask on the Flowplayer forum.

    Richard

  3. #3
    Join Date
    Jan 2012
    Posts
    27

    Default

    Hi Richard, I think I have narrowed it down. The onStart/onPause/onResume events are supposed to be generated for sanjose dvr streaming. The problem is intermittent. If I start wowza and then start the dvr it may or may not work. I have tried this several times and about 1 time in 4 everything works fine.
    I have saved two dvr folders from live streams form the same camera (an Axis P3364) that contain about a minute of content. I looked at the 0000_00_00/dvrManifest_0000_00_00.txt files and on the dvr that we don't get the flowplayer onStart events we see this at the top of the file:


    <dvrEntry index="0" type="0" start="0" packetTime="290455759" utcTime="1381894315270" stop="0" size="841" artifact="M-0000_00_00_000.m4fm" metadata="AgAKb25NZXRhRGF0YQMADHZpZGVvY29kZWNpZAIABGF2YzEADXZpZGVvZGF0YXJhdGUAQOhqAAAA
    AAAADWF1ZGlvY2hhbm5lbHMAP/AAAAAAAAAAD2F1ZGlvc2FtcGxlcmF0ZQBAz0AAAAAAAAAMYXVk
    aW9jb2RlY2lkAgAEbXA0YQANYXVkaW9kYXRhcmF0ZQBAUAAAAAAAAAAJdHJhY2tpbmZvCgAAAAID
    AAl0aW1lc2NhbGUAQPX5AAAAAAAACGxhbmd1YWdlAgADZW5nABFzYW1wbGVkZXNjcmlwdGlvbgoA
    AAABAwAKc2FtcGxldHlwZQIABEgyNjQAAAkABHR5cGUCAAV2aWRlbwAQcHJvZmlsZS1sZXZlbC1p
    ZAIABjRkMDAyOQAUc3Byb3AtcGFyYW1ldGVyLXNldHMCACVaMDBBS2VLUUNnRExZQzNBUUVCcEI0
    a1JVQT09LGFPNDhnQT09AAAJAwAJdGltZXNjYWxlAEDPQAAAAAAAAAhsYW5ndWFnZQIAA2VuZwAR
    c2FtcGxlZGVzY3JpcHRpb24KAAAAAQMACnNhbXBsZXR5cGUCAA1tcGVnNC1nZW5lcmljAAAJAAR0
    eXBlAgAFYXVkaW8ABmNvbmZpZwIABDE0MDgAC2Rlc2NyaXB0aW9uAgBXe0FBQ0ZyYW1lOiBjb2Rl
    YzpBQUMsIGNoYW5uZWxzOjEsIGZyZXF1ZW5jeToxNjAwMCwgc2FtcGxlc1BlckZyYW1lOjEwMjQs
    IG9iamVjdFR5cGU6TEN9AAAJAA5ydHBzZXNzaW9uaW5mbwMADGVtYWlsYWRkcmVzcwIABE5PTkUA
    BG5hbWUCABJNZWRpYSBQcmVzZW50YXRpb24ABm9yaWdpbgIAOS0gMTM4MTg5NDMxNDMxNjIzMiAx
    MzgxODk0MzE0MzE2MjMyIElOIElQNCAyMDguNzQuMTgzLjIyNgAGdGltaW5nAgADMCAwAA9wcm90
    b2NvbHZlcnNpb24CAAEwAAphdHRyaWJ1dGVzAwAFcmFuZ2UCAA1ucHQ9MC4wMDAwMDAtAAAJAAAJ
    AAAJ" />
    <dvrEntry index="0" type="998" start="0" packetTime="290455682" utcTime="1381894315304" chunkIndex="0" dvrTime="0" />
    Whereas in the 0000_00_00/dvrManifest_0000_00_00.txt of the dvr stream that does give the flowplayer onStart event we see the following as the first line:


    <dvrEntry index="0" type="998" start="0" packetTime="290296985" utcTime="1381894156685" chunkIndex="0" dvrTime="0" />
    Is this a configuration issue? a bug? ??

    Let me know if you need anything else. The dvr files come from Wowza 3.6.2 with Patch 16 applied.

    Thanks,
    Jo

Similar Threads

  1. Event/Notification that point out chunk creation of nDVR
    By spiritsoul in forum AddOn: Wowza nDVR
    Replies: 8
    Last Post: 07-22-2013, 09:19 AM
  2. nDVR playback is not smooth using flowplayer plugin
    By dpakrk in forum AddOn: Wowza nDVR
    Replies: 1
    Last Post: 08-06-2012, 10:54 AM
  3. Flowplayer
    By rob6894 in forum General Forum
    Replies: 1
    Last Post: 05-01-2012, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •