Results 1 to 4 of 4

Thread: RTSP Wowza 3 problem

  1. #1
    Join Date
    Jun 2013

    Default RTSP Wowza 3 problem

    Hi everyone!

    I have another problem with RTSP vod. I have installed Wowza 3.6.2 with a developer license and I have tested my Android-Wowza-based app on Nexus 7 (Android 4.3) and Samsung phone (Android 2.3.6) over WIFI.

    I created an application in Wowza, and I configured VHost.xml and Application.xml for Wowza to accept requests from external IP. The Nexus 7 is able to play video from Wowza using my external IP with both my app and Android internet explorer.

    The samsung phone is NOT able to play video from Wowza using my external IP (neither my app nor internet explorer works). It just works with INTERNAL Network IP.

    However, I have tried to play the sample video in Wowza demo page (I assume the version that is streaming in that demo page is a Wowza 3.x.x) using the internet explorer only and it works!

    Another detail I observed, which is rarer, is that Wowza logged the incoming request of the Samsung phone when using external ip and even logged the play stream message but phone state was just "loading video" until the error message appeared.

    Is there a further configuration needed on the router or something?

    Thanks in advance.


  2. #2
    Join Date
    May 2013


    Some questions:

    - Are there errors in your logs? What does it say surrounding the play log event?
    - Are you able to get the device console logs as well to see if anything can be obtained from that end?
    - Can you view the stream from outside your network with your public IP?

  3. #3
    Join Date
    Jun 2013


    Hi matt,

    Nope, there aren't error in logs. The logs I can see are the normal ones: app start, create stream, unpause, play.
    The logs in Samsung phone (Android logcat) are also normal but I can't read the "start" log in Android used to indicate that the VideoView object is playing and after a while, I get errors in logcat and closed stream log in Wowza.
    Yes, I can view the stream from outside my network with my public IP with Nexus 7.

    I think the problem is related with the streaming port, I mean, Nexus 7 can read from port 1935 or 554 for instance, but Samsung phone seems to read fine from port 554 only which is weird because I have both ports open in my router.


  4. #4
    Join Date
    Sep 2011


    Have you tried using Apple HLS with your Android devices?
    Are you using sample.mp4 for testing or are you using a different file?

    A tutorial for configuring a Wowza application for RTSP/RTP streaming can be found here,

    You can find a troubleshooting guide for RTSP/RTP playback below which may help you find the issue.

    What URL are you using for playback?
    Please not in the troubleshooting guide the resolutions which are known to cause issues.


Similar Threads

  1. Wowza Server 3.6.2 and RTSP Black Screen problem
    By alexeywhatt in forum General Forum
    Replies: 5
    Last Post: 12-11-2013, 06:17 AM
  2. Problem to get Wowza to connect to rtsp Stream
    By rudinussi in forum Tutorials Discussion
    Replies: 6
    Last Post: 05-22-2012, 06:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts