Results 1 to 7 of 7

Thread: Very unstable bandwidth usage?

  1. #1

    Default Very unstable bandwidth usage?

    Hello!

    Testing Wowza Transcoder addon. Input is mpeg2, 720x576x25fps.

    Output is default transcode.xml template for 360p.

    Given the xml, it is supposed to be somewhere around 900kb.

    But practically stream fluctuates a lot and jumps to as high as 1.5-1.7mb

    There are no connection or CPU issues. Encoding the same input with very similiar settings in VLC produce 400-900kb output.

    Any advice? Thanks!
    Last edited by AlexeyTs; 10-02-2013 at 07:27 AM.

  2. #2
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi,

    Can you try using this technique to find out which transcoding parameters are used.
    Can you check if CBR parameter is enabled or not?

    Zoran

  3. #3

    Default

    Quote Originally Posted by zoran_u View Post
    Hi,

    Can you check if CBR parameter is enabled or not?

    Zoran
    No, VBR is used

    2013-10-02 18:12:27 EEST comment server INFO 200 - # long: bit_rate_mode: bit rate stuff: 0=H264_CBR, 1=H264_CQT, 2=H264_VBR or 3=H264_TQM - - - 20.565 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-02 18:12:27 EEST comment server INFO 200 - mainconcept.bit_rate_mode: 2 - - - 20.565 - - - - - - - - - - - - - - - - - - - - - - - - -

    Shell i try with CBR?

  4. #4
    Join Date
    Jun 2012
    Posts
    723

    Default

    Yes, try adding the following parameter to your encoding Video/Parameters block:
    <Parameter>
    <Name>mainconcept.bit_rate_mode</Name>
    <Value>0</Value>
    <Type>Long</Type>
    </Parameter>

    Zoran

  5. #5

    Default

    Quote Originally Posted by zoran_u View Post
    Yes, try adding the following parameter to your encoding Video/Parameters block:
    <Parameter>
    <Name>mainconcept.bit_rate_mode</Name>
    <Value>0</Value>
    <Type>Long</Type>
    </Parameter>

    Zoran
    Zoran, i changed rate mode to CBR, it made almost no difference. It still jumps high over the limit. I was trying different buffer and max buffer size settings in VBR mode, playing with resolution. No success. Noticed that with certain resolution settings encoding does not start, black square and audio are broadcasted instead.

    What are the restrictions to resolution/screen ratio/bitrate modes, and what is the best way to limit the bandwidth? Lets say, i need my feeds to never exceed 1mbps. What is the best way to achieve it?

    Many Thanks.

  6. #6

    Default

    Also i noticed the following setting in transcode.xml:

    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>

    But playback always starts almost immediately - does not look like its real 60 key frame interval?

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    KeyFrameInterval setting should not affect playback start time.

    In my tests with those CBR settings, and other reports, not much difference either. You will probably have more effect looking at the source.

    Richard

Similar Threads

  1. High bandwidth usage
    By Doron@Softweave in forum Wowza Streaming Engine functionality
    Replies: 5
    Last Post: 05-03-2014, 04:16 AM
  2. Excessive bandwidth usage
    By devguy101 in forum AddOn: Transcoder
    Replies: 3
    Last Post: 10-24-2013, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •