Results 1 to 5 of 5

Thread: VLC to Wowza *.sdp streaming

  1. #1
    Join Date
    Aug 2013
    Posts
    13

    Default [SOLVED] VLC to Wowza *.sdp streaming

    Hello,

    My aim is to watch "H264 video stream" from Wowza location.

    "Source pc" is windows based and I create myStream.sdp file, then ftp it into "wowza server" wowza_directory/conf folder.

    Then I open streammanager page and add live video stream with myStream.sdp name.

    It shows "streaming published".

    In the following steps, the tutorial says:

    "In Wowza Media Server 3.5.0 and later, double-click [install-dir]/examples/LiveVideoStreaming/FlashRTMPPlayer/player.html, enter the information below, and then click the Connect button.

    Server: rtp://[wowza-ip-address]/live
    Stream: myStream.sdp"


    As wowza server is not at my own location, I copied related example folders into my pc and tried above explanations.
    It gives no error message but it does not play it on the related player.html page.

    When I try to run it with:

    rtsp://wowza_ip:1935/live/myStream.sdp
    In ssh panel, i see:

    INFO rtsp connect 1907248081 -
    INFO stream create - -
    INFO stream unpublish - -
    INFO stream destroy - -
    INFO rtsp disconnect 1907248081 -


    Can anybody advise me what to do?

    Thanks in advance
    Tinkerbell
    Last edited by tinkerbell; 10-04-2013 at 09:34 AM.

  2. #2
    Join Date
    Aug 2013
    Posts
    13

    Default

    I restarted the streaming at the source location and re-loaded the myStream.sdp file with some changes.
    To be sure I ftp'd the same myStream.sdp file into conf folder and into examples folder.
    Right now, when i open
    rtsp://wowza_ip:1935/live/myStream.sdp
    in VLC, what I see in ssh window is:

    INFO stream destroy myStream.sdp -
    INFO session disconnect 2131247494 -
    INFO session connect-pending ***.***.101.242 -
    INFO session connect ***.***.101.242 -
    INFO stream create - -
    WARN server comment - Application folder ([install-location]/applications/_definst_) is missing

    When I check related tutorial, it is said, the reason is " This error is generated when you connect to Wowza Media Server with no application name."
    When I delete _definst_ definition in streammanager page, it gives the same error.

    Where am I doing wrong?

    your advise will be highly appreciated

    Thanks
    Tinkerbell
    Last edited by tinkerbell; 10-03-2013 at 07:41 PM.

  3. #3
    Join Date
    Aug 2013
    Posts
    13

    Default

    Location1 (house pc):

    in VLC, i streamed a live video content with below parameters:
    :sout=#transcode{vcodec=h264,vb=1024,fps=25,scale=2,width=640,height=480,acodec=mp3,ab=64,channels=2,samplerate=44100}:duplicate{dst=rtp{dst=wowza_ip_address,port=1935,sdp=file:///C:\sdp\myStream.sdp,ttl=12},dst=display} :sout-all :sout-keep
    This is myStream.sdp file:

    v=0
    o=- ***18397806980410*** ***18397806980410*** IN IP4 Tinkerbell-Pc
    s=Unnamed
    i=N/A
    c=IN IP4 144.76.110.184
    t=0 0
    a=tool:vlc 2.0.7
    a=recvonly
    a=type:broadcast
    a=charset:UTF-8
    m=audio 1935 RTP/AVP 14
    b=AS:64
    b=RR:0
    a=rtpmap:14 MPA/90000/2
    a=rtcp:1936
    m=video 1937 RTP/AVP 96
    b=AS:1024
    b=RR:0
    a=rtpmap:96 H264/90000
    a=fmtp:96 packetization-mode=1;profile-level-id=64001e;sprop-parameter-sets=Z2QAHqzZQKA9sBEAAAMAAQAAAwAyjxYtlg==,aOvssiw=;
    a=rtcp:1938

    Location2 (wowza server:
    I installed wowza & apache into Debian based server.
    http://[wowza-ip-address]:1935
    It shows:
    Wowza Media Server 3 Trial Edition (Expires: Oct 31, 2013) 3.6.2 build5334
    To be sure again, I played sample.mp4 in location 1.
    I opened VLC and typed:

    rtsp://wowza_server_ip:1935/vod/mp4:sample.mp4
    movie started.

    Then I ftp'd myStream.sdp file into wowza_directory/conf & into wowza_directory/conf/live
    Also I ftp'd myStream.sdp file into examples/LiveVideoStreaming/Conf/Live

    I copied wowza_directory/conf/examples into /var/www
    I also copied myStream.sdp file into var/www/examples/LiveVideoStreaming/Conf/Live

    at streammanager page, I added sdp file streaming and it says:

    "publish stream successfully strated [live/_definst_]:flv:myStream.sdp

    At location1, i opened firefox and typed:

    http://wowza_server_ip/LiveVideoStre...er/player.html

    RTMP Player page displayed.
    server: rtmp://localhost/live
    stream: myStream.sdp
    It gives:
    "Connection failed: Try rtmp://[server-ip-address]/live" error

    RTMP Player page displayed.
    server: rtmp://wowza_dynamic_ip/live
    stream: myStream.sdp
    It gives:
    "Failed to play myStream.sdp; stream not found." error

    I am gonna scratch my head.

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    You need to move "myStream.sdp" to the [Wowza-Install]/content directory.
    When you have the file in the correct place it should start without issue.

    Jason

  5. #5
    Join Date
    Aug 2013
    Posts
    13

    Default

    Quote Originally Posted by JasonH View Post
    Hi,
    You need to move "myStream.sdp" to the [Wowza-Install]/content directory.
    When you have the file in the correct place it should start without issue.

    Jason
    working now!

    thank you so much
    Tinkerbell

Similar Threads

  1. VLC-SDP publish problem
    By erbora00 in forum General Forum
    Replies: 4
    Last Post: 04-09-2012, 03:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •