Results 1 to 3 of 3

Thread: Versioned MP4 not playing

  1. #1
    Join Date
    Oct 2013
    Posts
    5

    Question Versioned MP4 not playing

    I record all live streams using the rtp-record MediaCaster type. However, in some cases the live stream breaks and resumes (probably because the Internet connection is flaky). It's not a problem per se, but it creates a new versioned video for the recording (_0.mp4, _1.mp4, etc). The problem is that only the unversioned file is playable (i.e.: example.mp4 works, example_0.mp4 doesn't). There is no .tmp file. Is there something I can do? Can I make Wowza append to the file instead of versioning it? Would it fix the problem? Thanks!

  2. #2
    Join Date
    Jun 2012
    Posts
    722

    Default

    Hi,

    In order to have your recordings appended, in your Application.xml file, you will have to use the "live-record" stream type, and also add these properties to the Streams/Properties block:
    <Properties>
    <Property>
    <Name>versionFile</Name>
    <Value>false</Value>
    <Type>Boolean</Type>
    </Property>
    <Property>
    <Name>appendFile</Name>
    <Value>true</Value>
    <Type>Boolean</Type>
    </Property>
    </Properties>
    You should also keep using the rtp-record MediaCaster type from the Stream Manager.

    Zoran
    Last edited by zoran_u; 10-10-2013 at 03:11 AM.

  3. #3
    Join Date
    Oct 2013
    Posts
    5

    Default

    Quote Originally Posted by zoran_u View Post
    Hi,

    In order to have your recordings appended, in your Application.xml file, you will have to use the "live-record" stream type, and also add these properties to the Streams/Properties block:


    You should also keep using the ftp-record MediaCaster type from the Stream Manager.

    Zoran
    Thanks, that should take take of the appending portion. Let's see now if it fixes the bad videos.

Similar Threads

  1. MP4 file not playing in Iphone
    By sktniran in forum General Forum
    Replies: 6
    Last Post: 05-31-2013, 01:54 AM
  2. Recorded mp4 not playing on android
    By Xegagon in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 01-29-2012, 01:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •