Results 1 to 4 of 4

Thread: Wowza uses a lot of Virtual Memory!

  1. #1
    Join Date
    Dec 2012
    Posts
    28

    Default Wowza uses a lot of Virtual Memory!

    Hi guys

    I've installed WMS on one of my dedicated server with 2x CPUs and 32GB of RAM. I've installed latest version of CentOS 64bit and latest version of OpenJDK.
    When I start Wowza service, it uses a lot of virtual memory (like 12.1 GB)!

    I don't how to solve the problem. Can you please help me out.

    Thanks a lot.

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    You may be seeing this if you have the min (-Xms) defined to that size. This is just an initial reservation as completed by the JVM.

  3. #3
    Join Date
    Dec 2012
    Posts
    28

    Default

    I've done everything (Or maybe I've done everything wrong) to WMS but it still uses 12.1GB Virtual Memory!
    I've changed [install-dir]/bin/setenv.sh like this:
    #!/bin/sh
    _EXECJAVA=java
    JAVA_OPTS="-server -Xmx5000M"
    JAVA_OPTS="$JAVA_OPTS -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=512m"
    But nothing happened and WMS still using 12.1GB of Virtual Memory!

    Please help me figure this problem out.

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    We recommend Oracle Java rather than Open JDK.
    What does it say in the log when Wowza starts?

    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •