Results 1 to 7 of 7

Thread: Error while using new amazon ec2 control pannel

  1. #1
    Join Date
    Jan 2013

    Default Error while using new amazon ec2 control pannel

    Hey all,
    I am having an issue while trying to use our startup files with the new Amazon ec2 console. While all the zips where working fine last week once they went to the new console we seem to be getting errors. Here is a copy of the startup log:

    0 [main] INFO - Installer.doAmazonInstall
    1 [main] INFO - userdata-url:
    1 [main] INFO - userdata-destination: /opt/working/
    33 [main] INFO - userdata-isbase64: false
    33 [main] INFO - unzip: /opt/working/
    34 [main] ERROR com.wowza.util.ZipUtils - ZipUtils.unzipFile: error in opening zip file
    35 [main] INFO - result: /opt/working
    80 [main] ERROR - Installer.install: startup.xml file cannot be found at root of startup package. Check to be sure your startup package is properly zipped. It could contain too deep a directory structure.

    This is with the live startup zip right from the Wowza site. I get the same errors with all of my startup files. Has anyone else run into this problem and or found a solution for this. I have verifyied that the startup.xml is in the root of the zip file.

    Any help or advice would be greatly appreciated.


  2. #2
    Join Date
    Sep 2011


    The following workaround sorts out the problem with the new EC2 wizard.
    These instructions have been added to the EC2 AMI article.

    There is a known issue with the current version of the EC2 Management Console that does not work properly with the Wowza Media Server default startup package system. The work around is to specify the default startup package using the user data field as part of the AMI launch process. Do the following steps:

    In the Configure Instance Details step, open the Advanced Details section
    In the User data field enter the following user data and select the As text radio option


    The AMI's have been updated recently, can you tell us when you last started a new AMI?


  3. #3
    Join Date
    May 2013


    It looks like the general issue is with the zip file itself as it appears to be unable to unzip the file then resulting in a missing startup.xml. As a test, you could try one of our packages to see if there is an issue with the zip file you are testing.

  4. #4
    Join Date
    Jan 2013


    The last known good startup was on October 9th. We start a new server for each live event we do.

  5. #5
    Join Date
    Jan 2013


    The log above is actually using the right from your site. I downloaded it today.

  6. #6
    Join Date
    Dec 2007


    I've been testing this.

    I get the same result in Chrome using a local file. I tested with the file downloaded from the Wowza list of EC2 startup packages.

    It did work in Chrome with the method that Jason mentioned. In "Step 3: Configure Instance Details", Advanced Details in the User data field with the Text option selected, enter:
    Internet Explorer works with the local file.

    Using Firefox (latest version) I cannot even get to the AWS login page, I get 404 error, oddly.


  7. #7


    There does appear to be some issues with how the new interface handles files as userdata and it appears to vary depending on which browser you use. If it doesn't work, the file that arrives at the wowza instance appears to be corrupted.

    The method that Jason and Richard refer to should work on any browser but the zip file must reside on a web server or S3 account that your Wowza instance can access.

    Some browsers will also work by base64 encoding the local zip file and entering the base64 text into the userdata text box and selecting the check box that says the data is already base64 encoded. This worked with Chrome (Mac OSX).


Similar Threads

  1. control a Wowza EC2 Server via Amazon SDK / PHP
    By gerard in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 09-30-2012, 03:39 AM
  2. Replies: 5
    Last Post: 07-19-2012, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts