Results 1 to 5 of 5

Thread: Matrox Monarch HD

  1. #1

    Default Matrox Monarch HD

    Anyone else have one of these new appliances?

    I am looking for any how-to documentation for this device. One of our users bought one and is trying to push content to our server, but it appears that out of the box, it cannot connect unless I disable authentication or install a module to enable the password to be in the connection URL. However, doing that will ask clients to authenticate as well. Some workaround is mentioned in discussion, but I don't know exactly what I am looking for so I can't find the documentation for such a setup. I need to reboot the server today for the path 16 upgrade anyway, so I'd like to put whatever modules and settings in place when I do that.

    In case you don't know what device I am talking about - it is featured right here as a Wowza partner:


  2. #2
    Join Date
    Apr 2011


    Hi Peter

    I have one of these. I wouldn't think you'd be able to have authenticated streams supported with it as the stream settings page doesn't include any of that info. There's the option of using an XML file for config, but I'm not sure if you could put the auth details into it.

    On another note, let me know how satisfied you are with the unit in general. I've just started using mine and I'm not so happy at the moment. I'm finding the configuration screens to be difficult to use and buggy, the streams and recorded video produced jittery and the status/error messages produced abysmal. But apart from that, it's great! In any case it shows promise. I'm hoping that the issues I've seen will be able to be fixed by firmware updates.

  3. #3
    Join Date
    Jul 2012


    Hi all,

    Im using one Matrox Monarch HD since 3 months ago. I confess I am a little disappointed by this encoder `cos it has some problems with my Wowza version 4.0.6. When working for some days, the matrox status interface starts to display this message again and again:

    "RTMP Streaming["rtmp:// flashVer=\"FMLE/3.0 (compatible; FMSc/1.0)\! swfUrl=\"rtmp://\" pubUser=inti pubPasswd=XXXXXX"]: Error MEssage: "Could not open resource for writing."

    When this happens the streams seems to be connected, but you are unable to play anything. Test player displays an infinite spin (like loading) and nothing happens. I have to restart the encoder, the stream (and sometimes wowza server) to get the stream back.

    Any idea about how to solve this issue?

    Thx in advance.

  4. #4
    Join Date
    Jul 2016


    Did you fin a solution to stream in Wowza with Matrix Monarch HD because I have the same problem as you ?
    Thanks for your Answer

  5. #5
    Join Date
    Jan 2016


    Hi John,

    Do make sure that you first have the latest firmware for your Matrox. Monarch HD firmware version 2.0 (or later) is required to work with Wowza. You can download the latest firmware from their site here

    This article here covers streaming to Wowza Streaming Engine using Monarch HD.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts