Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Tandberg 8040 - voyager as encoder

  1. #1

    Default Tandberg 8040 - voyager as encoder

    Hi,

    I would like to use the above encorder as a MPEG TS UDP stream.

    The UDP stream is first tested locally with VLC. It works fine.

    Then to a EC2 CF created instance. The stream is received. However, I cannot playback. The question then is: is it Wowza or is it the client. I tried with Flash Media Player (OSMF).
    You can try to see the stream (colorbars + testtone) here: rtmp://54.216.32.194/livecf/mpegts.stream

    Te access log shows:
    2013-10-24 10:00:30 UTC comment server INFO 200 - RTPMediaCaster.Reconnector[217122198:livecf/_definst_:mpegts.stream]: done: 1 - - - 172.83 - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: handleTransportStreamBlock: new MPTS. - - - 172.831 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2PATAssembler:MonitorStart - - - 172.835 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2MPTS:StartStream: PID: 0x0 - - - 172.837 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - UDPTransport.firstPacket: bind:/0.0.0.0:10000 msg:/178.117.41.141:55190 - - - 172.839 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Received PAT - - - 172.87 - - - - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: PAT Version 1 - - - 172.871 - - - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Program: 0 PMT PID: 0x10 - - - 172.871 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Program: 1 PMT PID: 0x20 - - - 172.872 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2PMTAssembler:MonitorStart: PID: 32 Program Number: 1 - - - 172.874 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2MPTS:StartStream: PID: 0x20 - - - 172.874 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Received new PMT - - - 173.24 - - - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: PMT: Version 12 PCR pid: 0x65 - - - 173.242 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Stream: Type: 0x1B PID: 0x65 Video - - - 173.242 - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: Stream: Type: 0x04 PID: 0x100 Audio - - - 173.243 - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: RTPDePacketizerMPEGTS.pmtAvailable: IMPORT: videoPID[prg:0xffffffff,pid:0x65,filter:none]: streamType:H264:27 - - - 173.25 - - - - - - - - - - - - - - - - - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2MPTS:StartStream: PID: 0x65 - - - 173.255 - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: RTPDePacketizerMPEGTS.pmtAvailable: IMPORT: audioPID[prg:0x1,pid:0x100,filter:none]: streamType:MP3:4 audioLanguage:eng - - - 173.255 - - - - - - - - - - - - - - - - - --
    2013-10-24 10:00:30 UTC comment server INFO 200 - [livecf/_definst_/mpegts.stream]: MPEG2MPTS:StartStream: PID: 0x100 - - - 173.256 - - --
    2013-10-24 10:00:30 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.262 - - - - --
    2013-10-24 10:00:30 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.268 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.292 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.314 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.33 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.344 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.358 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.376 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.392 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.408 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.451 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.455 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.461 - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSanJose.init[livecf/_definst_/mpegts.stream]: chunkDurationTarget: 10000 - - - 173.462 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSanJose.init[livecf/_definst_/mpegts.stream]: chunkDurationTolerance: 500 - - - 173.463 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSanJose.init[livecf/_definst_/mpegts.stream]: playlistChunkCount:4 - - - 173.463 --
    2013-10-24 10:00:31 UTC comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer[livecf/_definst_/mpegts.stream]: Create live stream packetizer: sanjosestreamingpacketizer:mpegts.stream - - - 173.465 - - - - - - - - - - - - - - - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - SanJosePacketHandler.startStream[livecf/_definst_/mpegts.stream] - - - 173.467 - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSanJose.handlePacket[livecf/_definst_/mpegts.stream]: Video codec: H264 - - - 173.468 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSanJose.handlePacket[livecf/_definst_/mpegts.stream]: Audio codec: MP3 - - - 173.468 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.482 - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.init[livecf/_definst_/mpegts.stream]: chunkDurationTarget: 10000 - - - 173.491 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.init[livecf/_definst_/mpegts.stream]: chunkDurationTolerance: 500 - - - 173.492 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.init[livecf/_definst_/mpegts.stream]: audioGroupCount: 3 - - - 173.492 --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.init[livecf/_definst_/mpegts.stream]: playlistChunkCount:3 - - - 173.493 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.init[livecf/_definst_/mpegts.stream]: randomMediaName: media-u00l9506t - - -173.493 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.494 - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer[livecf/_definst_/mpegts.stream]: Create live stream packetizer: cupertinostreamingpacketizer:mpegts.stream - - - 173.497 - - - - - - - - - - - - - - - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - CupertinoPacketHandler.startStream[livecf/_definst_/mpegts.stream] - - - 173.498 - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[livecf/_definst_/mpegts.stream]: Video codec:H264 isCompatible:true - -173.499 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[livecf/_definst_/mpegts.stream]: Audio codec:MP3 isCompatible:true - -173.499 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.518 - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer[livecf/_definst_/mpegts.stream]: Create live stream packetizer: smoothstreamingpacketizer:mpegts.stream - - - 173.521 - - - - - - - - - - - - - - - - - - --
    2013-10-24 10:00:31 UTC comment server INFO 200 - LiveStreamPacketizerSmoothStreaming.startStream[livecf/_definst_/mpegts.stream] - - - 173.524 - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - LiveStreamPacketizerCupertino.handlePacket[livecf/_definst_/mpegts.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices. - - - 173.525 - - - - - - - - - - - - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - LiveStreamPacketizerSmoothStreaming.handlePacket[livecf/_definst_/mpegts.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player. - - - 173.529 - - - - - - - - - - - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count: -1 - - - 173.531 - - - - --
    2013-10-24 10:00:31 UTC comment server WARN 200 - LiveStreamPacketizerSanJose.handlePacket[livecf/_definst_/mpegts.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player. - - - 173.533 - -

    So video is compatible, audio may not be (MPEG Layer2).

    I tried adding transcoder but that does not seem to solve the problem.

    Any suggestions ? I have a live event in 2 weeks and prefer such a professional encoder versus Wirecast (that is working fine at the moment).

    Arne
    Last edited by arnevanrenterghem; 10-24-2013 at 03:17 AM. Reason: added stream address

  2. #2

    Default

    Hi,

    In the meantime I corrected an error in the transcoder (the Application livecf had a typo). The audio is now heard on the transcoded stream. The video is black.
    transcoded: rtmp://54.216.32.194/livecf/mpegts.stream_720p (audio OK, video black)
    direct: rtmp://54.216.32.194/livecf/mpegts.stream (no audio, video black)

    Thanks for any clues: ideally I would like to transcode the audio only en leave the video straight from the encoder.

    Arne

  3. #3
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    You can find an article which helps troubleshoot common error messages found in the Wowza logs.
    How to troubleshoot error messages

    From the WARN message below:
    RTPPacketFragmentListReader.skip: Bad skip count: -1

    I can see the following cause:
    Cause: This indicates packet loss or an incomplete packet. This message can occur when CPU utilization or GPU utilization for acceleration is at maximum capacity or beyond workable threshold, or if there is too much network traffic. Make sure Wowza Media Server has been tuned. See the Performance Tuning article.

    The message:
    MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by (Flash player, Silverlight player, on iOS devices).

    This generally means that you will have to transcode the audio to AAC using the Wowza transcoder if it doesn't play with the above devices.
    I see you have mentioned trying this already but if you're not getting a stream at all this is not the primary issue.

    I can't see any packetization in the logs provided, this generally happens when the stream doesn't have any keyframes (this may be logs but not in the section posted).

    Please see the article below,
    How to integrate your Wowza EC2 instance with CloudFront

    Jason

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    I just tried playing the stream with VLC player and I don't get a video track.
    rtsp://54.216.32.194/livecf/mpegts.stream
    VLC player - Tools > Codec Information:
    Stream 0
    Type: Audio
    Codec: MPEG Audio layer 1/2/3 (mpga)
    Channels: 1

    Stream 1
    Type: Audio
    Codec: MPEG Audio layer 1/2/3 (mpga)
    Channels: Mono
    Sample rate: 48000 Hz
    Bitrate: 96 kb/s

    For the transcoded stream with VLC player:
    rtsp://54.216.32.194/livecf/mpegts.stream_720p
    Stream 0
    Type: Audio
    Codec: MPEG AAC Audio (mp4a)
    Channels: 1
    Sample rate: 48000 Hz

    Stream 1
    Type: Audio
    Codec: MPEG AAC Audio (mp4a)
    Channels: Stereo
    Sample rate: 48000 Hz
    Bitrate: 96 kb/s

    This would explain why I the stream doesn't have any keyframes.

    Jason

  5. #5

    Default

    Yes, that is correct.

    What is the format of the MPEG2-TS stream that Wowza expects ? PAT, PMT, Video PID, Audio PID and so on. DVB or ATSC ? I believe the problem is that the videotrack is not found ? Exact the same settings, but streaming locally to my laptop with VLC gives:
    Stream 0
    Type: Video
    Original ID: 101
    Codec: H264-MPEG4-AVC (PART 10) (h264)
    Resolution: 1280x720
    Framerate: 100
    Decoded format: Planar 4:2:0 YUV

    Arne

  6. #6

    Default

    I use WMS panel to check on the transcoder and I find this:

    Transcoder Info
    VHost: _defaultVHost_
    Application name: livecf
    Application instance: _definst_
    Stream name: mpegts.stream
    Transcoder name: transcoder
    Start time: 2013-10-24T13:31:13.712Z
    Reset time: 2013-10-24T13:31:13.712Z

    Input Stream

    Audio
    CodecStr: mp4a.40.33
    Codec: MP3
    Audio object type: N/A
    Audio Channels: 1
    Audio sample frequency: 48000
    Audio samples per frame: 1152
    Stream name group Stream Name Video Info Audio Info
    all mp4:mpegts.stream_720p N/A AAC/fq:48000

    So, indeed, no input videostream and still it it there since changing the IP adress to my laptop gives a perfect image and sound.

    So, maybe Wowza expect the video to be on a specific PID ?

    Thx,

    Arne

  7. #7
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    You can certainly specify ProgramID as well as videoID and audioID using parameters in the .stream file by following this guide here.

    Daren

  8. #8
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    Have you tried adding the Properties to fix audio and video alignment from the MPEG-TS based encoder tutorial?
    MPEG-TS based encoder tutorial

    I recommend adding each Property one at a time and then the combinations of multiple Properties in the Application.xml
    Please post the Application.xml file in this thread with all properties enabled should this issue persist after trying the combinations explained above.

    Thanks,
    Jason

  9. #9

    Default

    Hi Jason,

    I tried the ProgramId and audio and so on. No luck.

    I also tried the syncing but also no luck. The PCR bit is set in the encoder anyway.

    The video is there, but once passed Wowza it's not there any more.

    It still can be the MPEG2 structure (e.g. if Wowza only accepts ATCS (american) and not DVB (european).

    But: are there possible problems with the H.246 encoding ? Does Wowza accept I B and P frames ? What size can the GOP size be ? Or is Wowza using the same decoding engine as VLC ?

    Thanks, this problem is really bugging me. It would be great if we could solve this. I just don't want to rely on the Wirecast/software solution. It's a bit too unstable for my taste.

    A

  10. #10
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    I see you tried the recommendations by Daren but did you try any of the alignment Properties from the troubleshooting section of the guide I provided?

    I think it may be best if you open a ticket so we can look at this issue in more detail, to open a ticket please email support@wowza.com.
    When opening a ticket, attach a zipped copy of the [Wowza-Install]/conf/ and [Wowza-Install]/logs/ directories for analysis and a link to this thread for reference.

    Thanks,
    Jason

Page 1 of 2 12 LastLast

Similar Threads

  1. [Tandberg/Wowza4] Problem with RTSP announcement
    By call_me_greg in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 07-09-2014, 05:15 AM
  2. [TCS] Tandberg emulation
    By gregory in forum Live Streaming and Encoder Discussion
    Replies: 6
    Last Post: 11-10-2011, 07:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •