Results 1 to 6 of 6

Thread: HDS manifest

  1. #1

    Default HDS manifest

    <manifest xmlns="http://ns.adobe.com/f4m/1.0">
    <id>xxxxxx.smil</id>
    <width>640</width>
    <height>360</height>
    <mimeType>video/mp4</mimeType>
    <streamType>live</streamType>
    <deliveryType>streaming</deliveryType>
    <bootstrapInfo id="bootstrap550" profile="named" url="playlist_b550.abst"/>
    <media bootstrapInfoId="bootstrap550" width="480" height="270" bitrate="1" url="media_u510vn7la_b550.abst/">
    <metadata>
    AgAKb25NZXRhRGF0......
    </metadata>
    </media>
    <bootstrapInfo id="bootstrap1050" profile="named" url="playlist_b1050.abst"/>
    <media bootstrapInfoId="bootstrap1050" width="640" height="360" bitrate="1" url="media_um7gdk4fu_b1050.abst/">
    <metadata>
    AgAKb25NZXRhRGF......
    </metadata>
    </media>
    </manifest>
    coming from this smil

    <smil>
        <head>
        </head>
        <body>
            <switch>
                     <video src="0_iuivnpkc_1.stream" system-bitrate="550"/>
                     <video src="0_iuivnpkc_2.stream" system-bitrate="1050"/>
            </switch>
        </body>
    </smil>
    on Wowza Media Server 3 Monthly Edition 3.6.2 build5334


    Why is the bitrate calculated as "1" on both? Doesnt look right.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I'm not sure. In my test with smil pointing to file, and smil pointing to a MediaCaster stream, I get correct bitrate values in the manifest.f4m. Even with the MediaCaster source turned off the manifest.f4m returns the correct bitrate. It is possible applying the latest patch will help.

    Richard

  3. #3
    Join Date
    Dec 2013
    Posts
    2

    Default

    I am having a similar issue on a system running Wowza 3.1.1

    The smil file for live stream:
    <smil>
    <head>
    </head>
    <body>
    <switch>
    <video src="mp4:mainfeed_pip_768-8.sdp" system-bitrate="768" width="1280" height="720">
    <param name="audioCodecId" value="mp4a.40.2" valuetype="data"/>
    <param name="videoCodecId" value="avc1.66.31" valuetype="data"/>
    </video>
    <video src="mp4:mainfeed_pip_384-8.sdp" system-bitrate="384" width="640" height="360">
    <param name="audioCodecId" value="mp4a.40.2" valuetype="data"/>
    <param name="videoCodecId" value="avc1.66.30" valuetype="data"/>
    </video>
    </switch>
    </body>
    </smil>
    The HDS manifest for live stream

    <manifest xmlns="http://ns.adobe.com/f4m/1.0">
    <id>live-stream-8.smil</id>
    <width>1280</width>
    <height>720</height>
    <mimeType>video/mp4</mimeType>
    <streamType>live</streamType>
    <deliveryType>streaming</deliveryType>
    <bootstrapInfo id="bootstrap768" profile="named" url="playlist_b768_w2053430413.abst"/>
    <media bootstrapInfoId="bootstrap768" width="1280" height="720" bitrate="1" url="media_b768_w2053430413.abst/">
    <metadata>
    AgAKb25NZXRhRGF0YQgAA...AAJAAAJ
    </metadata>
    </media>
    <bootstrapInfo id="bootstrap384" profile="named" url="playlist_b384_w2053430413.abst"/>
    <media bootstrapInfoId="bootstrap384" width="640" height="360" bitrate="1" url="media_b384_w2053430413.abst/">
    <metadata>
    AgAKb25NZXRhR...JAAAJAAAJ
    </metadata>
    </media>
    </manifest>
    The bitrate is calculated as 1 in both cases leading to dynamic switching not working
    Is there a workaround or a fix ?

    The playlist.m3u8 has correct values
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=768,CODECS="avc1.66.31,mp4a.40.2",RESOLUTION=1280x720
    chunklist-b768.m3u8?wowzasessionid=420593433
    #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=384,CODECS="avc1.66.30,mp4a.40.2",RESOLUTION=640x360
    chunklist-b384.m3u8?wowzasessionid=420593433
    Last edited by rahild; 12-19-2013 at 03:02 AM.

  4. #4
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hello,

    Can you upgrade your server to the latest Wowza release? The current Wowza version is 3.6.3 and there were lots of issues fixed since 3.1.1.
    Here is the link with the upgrade instructions: http://www.wowza.com/forums/content....oduction-Build

    Please let us know if you are experiencing the same problem after the upgrade.

    Zoran

  5. #5
    Join Date
    Dec 2013
    Posts
    2

    Default

    I tried steps mentioned in Readme file in the WowzaMediaServer-3.x.x-3.6.3 package Still I am getting bitrate as 1.

    <manifest xmlns="http://ns.adobe.com/f4m/1.0">
    <id>live-stream-10.smil</id>
    <width>1280</width>
    <height>720</height>
    <mimeType>video/mp4</mimeType>
    <streamType>live</streamType>
    <deliveryType>streaming</deliveryType>
    <bootstrapInfo id="bootstrap768" profile="named" url="playlist_b768_w329087718.abst"/>
    <media bootstrapInfoId="bootstrap768" width="1280" height="720" bitrate="1" url="media_b768_w329087718.abst/">
    <metadata>
    AgAKb25NZ...AAAJAAAJ
    </metadata>
    </media>
    <bootstrapInfo id="bootstrap512" profile="named" url="playlist_b512_w329087718.abst"/>
    <media bootstrapInfoId="bootstrap512" width="854" height="480" bitrate="1" url="media_b512_w329087718.abst/">
    <metadata>
    AgAKb...AAJAAAJ
    </metadata>
    </media>
    </manifest>
    Few things to mention here. I am using a trail license for live streaming.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Sorry, missed it myself. The system-bitrate is in bits, not kbits. Change them to "768000" and "384000"

    Richard

Similar Threads

  1. Best Tuning for HDS?
    By johnpptz in forum Performance Tuning Discussion
    Replies: 2
    Last Post: 04-19-2013, 04:01 AM
  2. vod hds manifest
    By pidboretskyy in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 04-17-2013, 08:02 AM
  3. Generating playlist from manifest
    By tavius in forum AddOn: Wowza nDVR
    Replies: 1
    Last Post: 02-08-2012, 10:22 AM
  4. Manifest File Syntax
    By corwin in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 01-15-2012, 09:07 AM
  5. Replies: 3
    Last Post: 11-20-2011, 06:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •