Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Re-streaming live from IP camera on local network

  1. #1
    Join Date
    Oct 2013

    Default Re-streaming live from IP camera on local network


    First i want to thank you for this incredible service.
    I have only one question. I have just downloaded the trial version of Wowza Media Server and configured it on my dedicated web server with centos 5. Everything went smoothly but in the tutorial said that in order to send a link to a remote computer i have to copy the folder client to a my web server. But i do not have that folder. Is the trial version limited? We intend to purchase the server of course but we just wanted to test it first. I know it is an error on my part but i couldn't find more details in the tutorial. The camera is hooked up only on a local network and we can not see the stream unless we are connected on that network.

    Thank you for the help in advance.

    Best Regards,

  2. #2


    Hi Ana,
    What exactly do you want to achieve?

    Connect the IP camera to wowza and call the stream from anywhere in your network, but also outside your network?.
    Do you want to see the stream in a browser or for example in vlc?

    if so.
    you have to make an application in wowza + adjust the Application.xml to your needs.
    Restart wowza and just open the stream in vlc (rtsp://<ipadress_wowzaserver>:1935/streamname

    if you want to see it outside your network you have to configure your router and route port 1935 to the wowza server.

    if you want to see it in a webbrowser in and outside your network. at the streamname like this: rtmp://<outside_ipaddress>:1935/streamname
    you could use jwplayer or flowplayer or another webplayer for this. (to be sure jwplayer6 still has problems in IE9/10, so using jwplayer5 will be more successfull)
    assuming your webserver is located outside your office/home.

    Just tell me what your setup is. i might can give you more detailed information.
    the userguide is nice to know:

  3. #3
    Join Date
    Oct 2013


    Thank you for your quick reply. Yes i want to stream outside the network trough a browser for now maybe later in vlc or quicktime. For now i have the same setup from this tutorial: with this address in the stream file: rtsp://admin:studiom123@ I know this cannot work since the server is indeed outside of the network and this is the ip addres of the camera on our network. How can i setup jwplayer for example?

    Thank you for all your help.

    Best regards,

  4. #4


    You don't have to worry about your Camera ip address, because your Wowza Server will be the central server. If your server and ip camera are outside your network just use the external ip addresses or open the ports to the internal ipaddress.
    Download the script from jwplayer. edit the settings to your needs and upload it to a webbrowser. for further support about Jwplayer you can go to their forum, they have plenty of examples there.

    in your stream file you are using username and password. so you have setup secure streaming.
    Can you tell me what is working for now?

    Your example setup?
    IP camera IPaddress:
    Wowza Ipaddress:

    webserver: ? or an outside ip?

    open the ports needed (1935, 554) in your server firewall or forward the ports to your internal wowza server.

    call the stream from anywhere inside and outside your network
    just use the external ipaddress from your router
    or use the external ipaddress when your server is a datacenter

    you didnt have the application name in your rtsp stream. it should be like this
    Last edited by nlmaca; 10-31-2013 at 05:32 AM.

  5. #5
    Join Date
    Oct 2013


    The camera is in my network and the server is outside the network. For now this works on a local machine within the network which is the example setup. I then installed wowza on the dedicated server without any problem and made the same settings except for the .stream file (i did not make any changes to it but i knew it wouldn't work). The server's ip is The IP address of the camera is internal one. Since the server we intend to use for streaming is dedicated server used just for storing files and has only few setups i thought i use the cloud jwplayer with the wowza address. Where can i put the router's external address? In the .stream file? As for the firewall of the server, it's disabled. This is and iweb dedicated server.

  6. #6


    Hi Ana,

    it should be simple. instead of sending the stream to your local wowza server, send the stream to the outside wowza server

    change <application_name> with the application you made in wowza.

    after that just use vlc to test the stream
    open networkstream: rtsp://admin:studiom123@<application_name>/play1.sdp

    otherwise what does your wowza_access.log tell you?
    or do you get any other log messages?

  7. #7
    Join Date
    Oct 2013


    I did create application and setup the internal and external ip addresses but now the log says connection refused . The router is apple time capsule that works as a router. In the port section of the router application there is option to add access to a specific device. There are 5 options to fill. Public TCP Port (i added 554, 1935), Public UDP port (Nothing here), Private IP Adress ( - camera IP) Private TCP Port (554, 1935) and private UDP Port.

    Wowza's log : ERROR server comment - MediaCasterConnection.connect: Failed to connect[]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].

    Thank you again and sorry for the silly questions.

    Best Regards,
    Last edited by TheAnaMk; 10-31-2013 at 09:07 AM.

  8. #8


    Hi Ana,

    no problem. I went to the same struggeling with different setups. There is lots of documentation, but sometimes its hard to know which one you need.

    Below i will try to display what i mean and what i think your setup is.

    Your Home/Office
    IP camera :

    RTSP protocol (best to use port 554 or 1935 to the wowza server)

    Wowza Server:

    you don't have to open ports at your home/office router. (Firewalls only blocks Incoming ports, not outgoing). So the connection refused error is saying it can't connect to the WowzaServer. So something in your setup on the wowza servers is not ok.

    I don't know what you mean with setting up the internal and external ip addresses. The servers already has those when you have installed them (static or DHCP addresses).

    By the way when i look back in the tutorial i don;t see the authentication for the rtsp. maybe you got confused that the username and password is for the streammanager section.

    for now i assume your application name is 'live' what makes it a bit easier to explain

    Try this to stream to wowza: rtsp://

    following the tutorial: Quote:
    Use a text editor to create the file [install-dir]/content/ and set the contents of this file to the full RTSP/RTP URL of the camera. The file must have a .stream filename extension. For this tutorial, the file used is

    I think you also have to go through the tutorial again, because when using the setup like this you can't call your streamname: play.sdp because you made a file on your wowza server. It cant find the reference. Tell me what you did with the setup step by step. If you missed one thing it just doesnt work. Dont put real usernames and passwords on the forum, but i need to know your setup in detail.

    i don't have an ip camera. so testing the scenario is not possible.

  9. #9
    Join Date
    Oct 2013



    Sorry for the long wait my camera is not available during the weekend. The link suggested still shows this error: Failed to get the session[ConnectException: Connection refused]. As for the file i have this setup: rtsp://adminassword@ This worked on the local machine. As for the setup i did it like this:
    I created folder live in application and in conf directories and in conf file i pasted the application.xml.
    In that file i applied the changes suggested on the tutorial. I downloaded the already changed file.
    After that i created the .stream file with the contents from above (which worked on the local machine).
    I edited the admin.passwod file with username and password.
    After this i open the streammanager and start streaming and everything is ok at that end.
    I also created another application with these steps but in the application.xml copied in that application has these settings:


    It didn't work with those either. The router is apple time capsule that works as a router and when i go on cmd and put ipconfig it shows this address ( as a default gateway. The other ones are the external ip of the router.

    Thank you again for your help.
    Best Regards,
    Last edited by TheAnaMk; 11-04-2013 at 03:45 AM.

  10. #10


    How are you starting the stream?
    Are you using Stream Manager?

    For the file, you should just have the IP address of the camera:
    What type of IP camera are you using? As this may change what the URL format in the file.

    Also make sure there is not a .txt extension appended to the file name. This file should be placed in the [wowza-install-dir]/content folder

    Try changing these settings back to default to test:(these settings are the default)
    Last edited by salvadore; 11-04-2013 at 07:52 AM. Reason: Added info, and corrected mistake

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Replies: 1
    Last Post: 08-27-2014, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts