Results 1 to 4 of 4

Thread: Lip sync issue on iPad, video&audio is not synchronized

  1. #1
    Join Date
    Nov 2013
    Posts
    7

    Exclamation Lip sync issue on iPad, video&audio is not synchronized

    Hi,

    On our system, we push video(H.264) and audio(AAC-LC) RTP streams to Wowza publishing point, then use iPad to watch the live streaming from Wowza, we get the lip sync issue, audio is ahead of video about 5 seconds in 10 minutes, then if I refresh the player, the issue just gone, and then, video lags again..., this issue only happens on iPad, when we use Android or Silverlight to play the same program, there is no lip sync issue, does anyone know what's the problem?


    thanks,
    Last edited by dazhong1219; 11-06-2013 at 09:13 PM.

  2. #2

    Default

    This is usually an encoder issue. You can use this Property setting to see audio/video alignment in the logs:
    How to debug AAC or MP3 timecode issues with cupertino packetization

    Salvadore

  3. #3
    Join Date
    Nov 2013
    Posts
    7

    Default

    Thank you Salvadore, I did the debug, and it seems it's not timecode issue, because tc always equal to 0 or 1, but I still experience lip sync issue on iPad, it happens every time.

    Quote Originally Posted by salvadore View Post
    This is usually an encoder issue. You can use this Property setting to see audio/video alignment in the logs:
    How to debug AAC or MP3 timecode issues with cupertino packetization

    Salvadore

  4. #4

    Default

    Can you describe your encoder settings?
    FPS?
    Keyframe interval(GOP)
    Frame size
    Bitrate

    It could be that your FPS/GOP need to be modified.

    Also, take a look at this jitter buffer. it will log RTP packet loss and attempt to limit any packet loss issues:
    How to turn on an RTP jitter buffer and packet loss logging (RTP and MPEG-TS)

    One other thing to try is How to fix unaligned video and audio with a server-side sort buffer

    Salvadore

Similar Threads

  1. Lip Sync Issue on LiveStreams
    By sgopalkr in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 11-14-2012, 10:42 AM
  2. ipad video & audio out of sync in live stream
    By rviteri in forum General Forum
    Replies: 1
    Last Post: 06-30-2012, 03:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •