Results 1 to 5 of 5

Thread: MediaCache over port 80

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default MediaCache over port 80

    hi all,

    Several customers cannot use port 1935.

    I am using media cache plugin.

    The idea is to go thru port 80 instead of 1935.

    But a problem appear here.

    When i'm adding port 80 in VHost.xml

    <Root>
            <VHost>
                    <HostPortList>
                            <HostPort>
                                    <ProcessorCount>4</ProcessorCount>
                                    <IpAddress>*</IpAddress>
                                    <!-- Separate multiple ports with commas -->
                                    <!-- 80: HTTP, RTMPT -->
                                    <!-- 554: RTSP -->
                                    <Port>1935,80</Port>
                                    <HTTPIdent2Response></HTTPIdent2Response>
    Nothing work anymore even port 1935

    So i suppose, i am already wrong at this step?

    Next step would be (for example)

    rtmp://xx.xx.xx.xx:80/mediacache
    mp4:http/xxxxxxxx.fr/xxxxxx/xxxxxxx.mp4


    any ideas??

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    When you restart with port 80 added, what shows up in your logs? Bind errors?

  3. #3

    Default

    access.log file :

    2013-11-12      17:28:26        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       86.954  -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:31        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       91.961  -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:36        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       96.965  -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:41        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       101.971 -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:46        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       106.976 -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:51        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       111.979 -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -      $
    2013-11-12      17:28:56        CET     comment vhost   WARN    200     _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use       -       -       -       116.983
    error.log

    WARN    server  comment 2013-11-12      15:27:50        -       -       -       -       -       83.446  -       -       -       -       -       -       -       http/xxxxxx.mp4   MediaReaderH264.open[1]: java.io.IOException: MediaCacheRandomAccessReader.open: Item not in cache: http/xxxxxxx.mp4
    WARN    vhost   comment 2013-11-12      15:27:54        -       -       -       -       -       86.956  -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:27:59        -       -       -       -       -       91.964  -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:04        -       -       -       -       -       96.969  -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:09        -       -       -       -       -       101.976 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:14        -       -       -       -       -       106.98  -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:19        -       -       -       -       -       111.984 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    server  comment 2013-11-12      15:28:23        -       -       -       -       -       115.995 -       -       -       -       -       -       -       -       CommandInterfaceCommandShutdownServer.invoke: java.lang.NullPointerException
    WARN    vhost   comment 2013-11-12      15:28:24        -       -       -       -       -       116.988 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:29        -       -       -       -       -       121.996 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:34        -       -       -       -       -       127.003 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use
    WARN    vhost   comment 2013-11-12      15:28:39        -       -       -       -       -       132.008 -       -       -       -       -       -       -       _defaultVHost_  Bind failed, try again ([any]:80): java.net.BindException: Address already in use

  4. #4
    Join Date
    May 2013
    Posts
    680

    Default

    It looks like you have something already running on that port (80). Do you have apache or something similar running on that machine? Only one of them can occupy that port.

  5. #5

    Default

    Thanks,

    something was running on port 80

Similar Threads

  1. Replies: 1
    Last Post: 10-08-2014, 12:30 AM
  2. port 1936 vs port 1935
    By vision in forum Server Administration Discussion
    Replies: 1
    Last Post: 03-07-2012, 06:30 AM
  3. Seperate Admin Port and http / rtsp port
    By cussons in forum General Forum
    Replies: 1
    Last Post: 02-09-2012, 11:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •