Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: QuickSync not working on Ubuntu 13.04

  1. #1
    Join Date
    Nov 2013
    Posts
    8

    Default QuickSync not working on Ubuntu 13.04

    Hi,

    I have a machine using intell core i7 4770, and i have installed Ubuntu 13.04, and graphics driver.
    when i run vainfo, i have :
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_34
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.34 (libva 1.2.1)
    vainfo: Driver version: Intel i965 driver - 1.2.0
    vainfo: Supported profile and entrypoints
    VAProfileNone : VAEntrypointVideoProc
    VAProfileMPEG2Simple : VAEntrypointVLD
    VAProfileMPEG2Simple : VAEntrypointEncSlice
    VAProfileMPEG2Main : VAEntrypointVLD
    VAProfileMPEG2Main : VAEntrypointEncSlice
    VAProfileH264Baseline : VAEntrypointVLD
    VAProfileH264Baseline : VAEntrypointEncSlice
    VAProfileH264Main : VAEntrypointVLD
    VAProfileH264Main : VAEntrypointEncSlice
    VAProfileH264High : VAEntrypointVLD
    VAProfileH264High : VAEntrypointEncSlice
    VAProfileVC1Simple : VAEntrypointVLD
    VAProfileVC1Main : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD
    VAProfileJPEGBaseline : VAEntrypointVLD

    But, when i transcode a live stream, wowza server say :
    Intel Quick Sync hardware acceleration is NOT available.

    Please help me to run Intel Quick Sync on my wowza server !!!

    Thanks

  2. #2
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    Have you tried restarting Wowza after installing the drivers?
    I'm adding the link to the tutorial you used to make it easier for others to follow,
    How to setup Wowza Transcoder QuickSync accelerated encoding on Ubuntu Desktop

    Can you post a copy of your logs which include the "Intel Quick Sync hardware acceleration is NOT available" message from the Access.log file.

    Thanks,
    Jason

  3. #3
    Join Date
    Nov 2013
    Posts
    8

    Default

    Quote Originally Posted by JasonH View Post
    Hi,
    Have you tried restarting Wowza after installing the drivers?
    I'm adding the link to the tutorial you used to make it easier for others to follow,
    How to setup Wowza Transcoder QuickSync accelerated encoding on Ubuntu Desktop

    Can you post a copy of your logs which include the "Intel Quick Sync hardware acceleration is NOT available" message from the Access.log file.

    Thanks,
    Jason
    Thank you for your reply,

    I have tried to restart server, clear log, and re-streamming,
    Here is my Accesslog:
    #Version: 1.0
    #Start-Date: 2013-11-19 15:14:18 ICT
    #Software: Wowza Media Server 3.6.3 build8031
    #Date: 2013-11-19
    #Fields: date time tz x-event x-category x-severity x-status x-ctx x-comment x-vhost x-app x-appinst x-duration s-ip s-port s-uri c-ip c-proto c-referrer c-user-agent c-client-id cs-bytes sc-bytes x-stream-id x-spos cs-stream-bytes sc-stream-bytes x-sname x-sname-query x-file-name x-file-ext x-file-size x-file-length x-suri x-suri-stem x-suri-query cs-uri-stem cs-uri-query
    2013-11-19 15:14:18 ICT server-start server INFO 200 Wowza Media Server 3 Trial Edition (Expires: Dec 16, 2013) 3.6.3 build8031 - - - - 0.31 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Server License Key: SVRT3-XXXXX-XXXXX-XXXXX-XXXXX-Vf3Ee - - - 0.311 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Maximum Connections: Unlimited - - - 0.311 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Transcoder Streams Available: Unlimited - - - 0.314 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Transcoder Watermark: Yes - - - 0.314 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - nDVR Available: Yes - - - 0.314 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - DRM Available: Yes - - - 0.315 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Hardware Available Processors: 8 - - - 0.315 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Hardware Physical Memory: 2036MB/3466MB - - - 0.316 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Hardware Swap Space: 3305MB/3599MB - - - 0.316 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Max File Descriptor Count: 20000 - - - 0.317 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Open File Descriptor Count: 49 - - - 0.317 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - OS Name: Linux - - - 0.317 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - OS Version: 3.8.0-33-generic - - - 0.318 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - OS Architecture: amd64 - - - 0.318 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Name: Java HotSpot(TM) 64-Bit Server VM - - - 0.318 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Vendor: Oracle Corporation - - - 0.318 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Version: 1.7.0_45 - - - 0.319 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java VM Version: 24.45-b08 - - - 0.319 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Spec Version: 1.7 - - - 0.319 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Home: /usr/lib/jvm/java-7-oracle/jre - - - 0.319 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Max Heap Size: 1067MB - - - 0.32 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Architecture: 64 - - - 0.32 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Locale[user.language]: en - - - 0.32 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Locale[user.country]: US - - - 0.32 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Locale[file.encoding]: UTF-8 - - - 0.321 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Timezone[user.timezone]: Asia/Vientiane - - - 0.321 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[0]: -Xmx1200M - - - 0.321 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[1]: -Djava.net.preferIPv4Stack=true - - - 0.321 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[2]: -Dcom.sun.management.jmxremote=true - - - 0.322 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[3]: -Dcom.wowza.wms.runmode=service - - - 0.322 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[4]: -Dcom.wowza.wms.native.base=linux - - - 0.322 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[5]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaMediaServer - - - 0.322 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[6]: -Dcom.wowza.wms.ConfigURL= - - - 0.323 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Java Args[7]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaMediaServer - - - 0.323 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Server runmode: service - - - 0.323 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Server native.platform: linux - - - 0.323 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:18 ICT comment server INFO 200 - Server threads[h/t]: 10/10 - - - 0.324 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:20 ICT comment server INFO 200 - JMX java.rmi.server.hostname: 10.0.0.23 - - - 2.549 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:20 ICT comment server INFO 200 - JMX bind attempt service:jmx:rmi://10.0.0.23:8084/jndi/rmi://10.0.0.23:8085/jmxrmi - - - 2.549 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:20 ICT comment server INFO 200 - JMX bind successful - - - 2.596 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:20 ICT comment server INFO 200 - CMDInterface now listening: [any]:8083 - - - 2.61 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT vhost-start vhost INFO 200 _defaultVHost_ - - - - 3.024 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment server INFO 200 - _defaultVHost_ threads[h/t]:120/80 home:/usr/local/WowzaMediaServer - - - 3.056 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment vhost INFO 200 _defaultVHost_ Bind attempt ([any]:1935:4) - - - 3.059 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment vhost INFO 200 _defaultVHost_ Bind successful ([any]:1935) - - - 3.061 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment vhost INFO 200 _defaultVHost_ Bind attempt ([any]:8086:1) - - - 3.062 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment vhost INFO 200 _defaultVHost_ Bind successful ([any]:8086) - - - 3.063 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment server INFO 200 - Server.startShutdownHook: Start server shutdown hook - - - 3.065 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:21 ICT comment server INFO 200 - Wowza Media Server is started! - - - 3.066 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:26 ICT app-start application INFO 200 _definst_ vegatrancodes/_definst_ - - - 8.885 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:26 ICT connect-pending session INFO 100 10.0.0.35 - _defaultVHost_ vegatrancodes _definst_ 0.122 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 3193 3073 - - - - - - - - - - - - - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:26 ICT connect session INFO 200 10.0.0.35 - _defaultVHost_ vegatrancodes _definst_ 0.122 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 3193 3073 - - - - - - - - - - - - - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:26 ICT create stream INFO 200 - - _defaultVHost_ vegatrancodes _definst_ 0.014 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 3312 3413 1 0 0 0 - - - - 0 0.0 rtmp://10.0.0.23:1935/vegatrancodes rtmp://10.0.0.23:1935/vegatrancodes - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:26 ICT publish stream INFO 200 maxHtv71 - _defaultVHost_ vegatrancodes _definst_ 0.017 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 3362 3606 1 0 0 0 maxHtv71 - - - 0 0.0 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:27 ICT comment server INFO 200 - TranscoderSessionNative.loadLibrary: Load transcoder list: /usr/local/WowzaMediaServer/lib-native/linux64/transcoder.list - - - 9.145 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - LiveStreamTranscoder.init[vegatrancodes/_definst_/maxHtv71]: Load transcoder template: file:///usr/local/WowzaMediaServer/transcoder//Default.xml - - - 9.153 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.isCUDAAvailable[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: NVidia hardware acceleration is NOT available - - - 9.266 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.isQuickSyncAvailable[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: Intel Quick Sync hardware acceleration is NOT available. - - - 9.267 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT create stream INFO 200 - - - - - 0.0 - - - - - - - - - - 1 0 0 0 - - - - 0 0.0 - - - - -
    2013-11-19 15:14:27 ICT publish stream INFO 200 womaxHtv71 - - - - 0.001 - - - - - - - - - - 1 0 0 0 womaxHtv71 - - - 0 0.0 /womaxHtv71 /womaxHtv71 - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.videoDecoderCreate[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: Create video decoder: H.264: default - - - 9.325 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT decoder-video-start transcoder INFO 200 maxHtv71 {codec:H264, profile:Baseline, level:3.1, frameSize:640x480, displaySize:640x480, frameRate:25.0} - - - 9.338 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:VideoDecoderH264.updateDecodeInfo[global]: aspect:4x3 frame:640x480 display:640x480 frameRate:25 - - - 9.34 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:vegatrancodes/_definst_/maxHtv71:HMP]: Create video encoder: H.264: default - - - 9.341 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.audioDecoderCreate[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: Create audio decoder: MP3: default - - - 9.407 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT decoder-audio-start transcoder INFO 200 maxHtv71 {codec:MP3, objectType:MPEG1LAYER3, sampleRate:44100, channels:2} - - - 9.408 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:TranscoderSession.audioEncoderAdd[_defaultVHost_:vegatrancodes/_definst_/maxHtv71:HMP]: Create audio encoder: AAC: default - - - 9.409 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:AudioDecoderMP2.decodeFirstFrame[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: sampleRate:44100 channels:2 bitRate:128 version:1 layer:3 - - - 9.41 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - JNI:AudioEncoderAAC.initialize[_defaultVHost_:vegatrancodes/_definst_/maxHtv71:HMP]: channels:2 sampleRate:44100 bitRate:48000 - - - 9.412 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT encoder-audio-start transcoder INFO 200 maxHtv71 {name:"HMP", bitrate:48000, codec:AAC, objectType:LC, sampleRate:44100, channels:2} - - - 9.415 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT encoder-video-start transcoder INFO 200 maxHtv71 {name:"HMP", bitrate:100000, codec:H264, profile:Main, level:3.1, frameSize:400x300, displaySize:400x300, frameRate:25.0} - - - 9.87 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:27 ICT comment server INFO 200 - TranscoderStreamNameGroup.addInternal[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: Add name group: maxHtv71_all - - - 9.898 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT comment server INFO 200 - TranscodingSession.close[vegatrancodes/_definst_/maxHtv71] - - - 14.591 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT unpublish stream INFO 200 maxHtv71 - _defaultVHost_ vegatrancodes _definst_ 5.703 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 754779 3780 1 0 749325 0 maxHtv71 - - - 0 0.0 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:32 ICT comment server INFO 200 - TranscoderStreamNameGroup.removeInternal[_defaultVHost_:vegatrancodes/_definst_/maxHtv71]: Remove name group: maxHtv71_all - - - 14.6 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT destroy stream INFO 200 maxHtv71 - _defaultVHost_ vegatrancodes _definst_ 5.707 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 754779 3780 1 0 749325 0 maxHtv71 - - - 0 0.0 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 rtmp://10.0.0.23:1935/vegatrancodes/maxHtv71 - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:32 ICT comment server INFO 200 - TranscodingSession.shutdown[vegatrancodes/_definst_/maxHtv71] - - - 14.601 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT disconnect session INFO 200 840533526 - _defaultVHost_ vegatrancodes _definst_ 5.837 [any] 1935 rtmp://10.0.0.23:1935/vegatrancodes 10.0.0.35 rtmp - unknown 840533526 754779 3780 - - - - - - - - - - - - - rtmp://10.0.0.23:1935/vegatrancodes -
    2013-11-19 15:14:32 ICT decoder-video-stop transcoder INFO 200 maxHtv71 - - - - 14.602 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT decoder-audio-stop transcoder INFO 200 maxHtv71 - - - - 14.605 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT encoder-video-stop transcoder INFO 200 maxHtv71 {name: "HMP"} - - - 14.607 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT encoder-audio-stop transcoder INFO 200 maxHtv71 {name: "HMP"} - - - 14.608 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-11-19 15:14:32 ICT unpublish stream INFO 200 womaxHtv71 - - - - 5.335 - - - - - - - - - - 1 0 0 0 womaxHtv71 - - - 0 0.0 /womaxHtv71 /womaxHtv71 - - -
    2013-11-19 15:14:32 ICT destroy stream INFO 200 womaxHtv71 - - - - 5.337 - - - - - - - - - - 1 0 0 0 womaxHtv71 - - - 0 0.0 /womaxHtv71 /womaxHtv71 - - -
    And my error log is blank

  4. #4
    Join Date
    Nov 2013
    Posts
    8

    Default

    Hi Jason,

    Do you need more infomation?, please help me!!

  5. #5

    Default

    Hi,

    It looks like from your logs that you are running Wowza as a service.

    In this case, QuickSync may not work as it does require a desktop session to be running so that it can access the X-Server libraries it needs.

    I think the problem with Ubuntu is that the MIT-MAGIC-COOKIE-1 value is different every time a user logs in so needs to be updated manually for the root user to be able to start Wowza.

    Roger.

  6. #6
    Join Date
    Nov 2013
    Posts
    8

    Default

    Thank Roger,

    Yes, I think the problem is MIT-MAGIC-COOKIE-1,
    I have two user on my ubuntu desktop. And I did a simple test with vainfo (When log in on GUI, run "sudo su" to get admin access),
    User 1: "Invalid MIT-MAGIC-COOKIE-1 keyerror: can't connect to X server!" at line 1
    Invalid MIT-MAGIC-COOKIE-1 keyerror: can't connect to X server!
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_34
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.34 (libva 1.2.1)
    vainfo: Driver version: Intel i965 driver - 1.2.0
    vainfo: Supported profile and entrypoints
    VAProfileNone : VAEntrypointVideoProc
    VAProfileMPEG2Simple : VAEntrypointVLD
    VAProfileMPEG2Simple : VAEntrypointEncSlice
    VAProfileMPEG2Main : VAEntrypointVLD
    VAProfileMPEG2Main : VAEntrypointEncSlice
    VAProfileH264Baseline : VAEntrypointVLD
    VAProfileH264Baseline : VAEntrypointEncSlice
    VAProfileH264Main : VAEntrypointVLD
    VAProfileH264Main : VAEntrypointEncSlice
    VAProfileH264High : VAEntrypointVLD
    VAProfileH264High : VAEntrypointEncSlice
    VAProfileVC1Simple : VAEntrypointVLD
    VAProfileVC1Main : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD
    VAProfileJPEGBaseline : VAEntrypointVLD
    User 2: ok ( No error)
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_34
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.34 (libva 1.2.1)
    vainfo: Driver version: Intel i965 driver - 1.2.0
    vainfo: Supported profile and entrypoints
    VAProfileNone : VAEntrypointVideoProc
    VAProfileMPEG2Simple : VAEntrypointVLD
    VAProfileMPEG2Simple : VAEntrypointEncSlice
    VAProfileMPEG2Main : VAEntrypointVLD
    VAProfileMPEG2Main : VAEntrypointEncSlice
    VAProfileH264Baseline : VAEntrypointVLD
    VAProfileH264Baseline : VAEntrypointEncSlice
    VAProfileH264Main : VAEntrypointVLD
    VAProfileH264Main : VAEntrypointEncSlice
    VAProfileH264High : VAEntrypointVLD
    VAProfileH264High : VAEntrypointEncSlice
    VAProfileVC1Simple : VAEntrypointVLD
    VAProfileVC1Main : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD
    VAProfileJPEGBaseline : VAEntrypointVLD
    And tried vainfo via putty (ssh)
    User 1 and 2: error: can't connect to X server!
    error: can't connect to X server!
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_34
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.34 (libva 1.2.1)
    vainfo: Driver version: Intel i965 driver - 1.2.0
    vainfo: Supported profile and entrypoints
    VAProfileNone : VAEntrypointVideoProc
    VAProfileMPEG2Simple : VAEntrypointVLD
    VAProfileMPEG2Simple : VAEntrypointEncSlice
    VAProfileMPEG2Main : VAEntrypointVLD
    VAProfileMPEG2Main : VAEntrypointEncSlice
    VAProfileH264Baseline : VAEntrypointVLD
    VAProfileH264Baseline : VAEntrypointEncSlice
    VAProfileH264Main : VAEntrypointVLD
    VAProfileH264Main : VAEntrypointEncSlice
    VAProfileH264High : VAEntrypointVLD
    VAProfileH264High : VAEntrypointEncSlice
    VAProfileVC1Simple : VAEntrypointVLD
    VAProfileVC1Main : VAEntrypointVLD
    VAProfileVC1Advanced : VAEntrypointVLD
    VAProfileJPEGBaseline : VAEntrypointVLD

    When user2 logged in with GUI, and run Wowza Server by using startup.sh file, Wowza server also said :Intel Quick Sync hardware acceleration is NOT available.

    Can you give me some information about MIT-MAGIC-COOKIE-1 value, and how to manual update this value

    Thank you !

  7. #7

    Default

    Quote Originally Posted by kiennh View Post
    Thank Roger,

    Yes, I think the problem is MIT-MAGIC-COOKIE-1,
    I have two user on my ubuntu desktop. And I did a simple test with vainfo (When log in on GUI, run "sudo su" to get admin access),
    User 1: "Invalid MIT-MAGIC-COOKIE-1 keyerror: can't connect to X server!" at line 1


    User 2: ok ( No error)


    And tried vainfo via putty (ssh)
    User 1 and 2: error: can't connect to X server!



    When user2 logged in with GUI, and run Wowza Server by using startup.sh file, Wowza server also said :Intel Quick Sync hardware acceleration is NOT available.

    Can you give me some information about MIT-MAGIC-COOKIE-1 value, and how to manual update this value

    Thank you !
    Hi,

    This is really out of our depth. I think it would be best to ask on one of the linux or X-Server forums.

    Roger.

  8. #8
    Join Date
    Nov 2013
    Posts
    8

    Default

    Hi,

    I've never seen Quick Sync work on my server,
    And the wowza log just say Quick Sync is not available, so I can't understand the problems here, and I don't know what wrong in my steps when i setting up Wowza server or XServer

    Can you help me?, I don't want to lose the intel hd 4600 graphic card on my transcode server

    Kiennh

  9. #9

    Default

    Hi,

    I think the problem that you are having is that you either have multiple users logged into the desktop at the same time or you are somehow connecting the root user to the wrong desktop.

    Wowza will try to use display 0:0 so your user needs to be logged into that one and root user needs to connect to that one by getting the cookie and then exporting the DISPLAY var.

    Restart the server and log into the desktop as a normal user.

    Follow step 3 & 4 in the Ubuntu instructions. How to set up Wowza Transcoder Quick Sync accelerated encoding on Ubuntu Desktop

    If the vainfo command runs correctly then the root user should be able to run Wowza and have the QuickSync transcoder available.

    If you are not worried about which type of Linux to use then CentOS is a lot easier to set up as it does not use the cookie system that Ubuntu uses.

    Roger.

  10. #10
    Join Date
    Nov 2013
    Posts
    8

    Default

    Thank you very much, Roger,

    I have few day to re-install and config Wowza transcode on Ubuntu but no luck ,
    And i have tried to use CentOS 6.4, but It's hard to install VAAPI, because the latest intel driver and intel graphics install require new libs or upgrade many libs
    Last edited by kiennh; 11-28-2013 at 02:45 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. GPU Utilization (QuickSync)
    By cdpearce in forum AddOn: Transcoder
    Replies: 2
    Last Post: 09-14-2016, 08:33 AM
  2. Problem with Transcoder and QuickSync
    By edumetz16 in forum Wowza Transcoder
    Replies: 1
    Last Post: 02-25-2014, 10:02 PM
  3. QuickSync, XAuthority, and Ubuntu 12.04.3
    By KLindgren in forum AddOn: Transcoder
    Replies: 1
    Last Post: 12-13-2013, 12:49 PM
  4. QuickSync + CentOS
    By bosborne in forum AddOn: Transcoder
    Replies: 1
    Last Post: 02-08-2013, 03:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •