Results 1 to 4 of 4

Thread: Wowza plays unspecified recorded file rather than the live publishing

  1. #1
    Join Date
    Nov 2013
    Posts
    3

    Default Wowza plays unspecified recorded file rather than the live publishing

    Hi,

    I am trying to publish and play a live stream through Wowza. In theory it should play live but instead, what I'm seeing happen is the video play a recording of the previous publishing. ie Despite seemingly not specifing this, the video gets recorded and gets viewed on the next viewing rather than the current.

    I am using the same Adobe Air app I have used through FMS so there doesn't seem to be a problem there.

    Server side I believe I have made the key changes to the application.xml which are necessary ie:

    <Streams>
      <StreamType>live</StreamType>
      <LiveStreamPacketizers>cupertinostreamingpacketizer, smoothstreamingpacketizer, sanjosestreamingpacketizet</LiveStreamPacketizers>
    </Streams>
    <HTTPStreamers>cupertinostreaming,smoothstreaming,sanjosestreaming</HTTPStreamers>
    <RTP>
      <Authentication>
        <PublishMethod>digest</PublishMethod>
        <PlayMethod>none</PlayMethod>
      </Authentication>
    </RTP>
    What else may be causing this?

    Thanks

  2. #2
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi,

    Can you send a complete set of Wowza configuration and log files to support@wowza.com so we can take a closer look?
    I'm sure it's a configuration issue and more clues can be found in Wowza logs.

    Zoran

  3. #3
    Join Date
    Nov 2013
    Posts
    3

    Default

    Thanks, I've made a quick work around just so that anyone curious wants to know (it's pretty simple as you might expect):

    Basically, I applied the changes to the applicaiton.xml file in the applications/MobileCommTest folder to the original conf/application.xml file and it works.

    Any idea why the application.xml in the specific application folder may not be applied?

    Thanks

  4. #4
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi,

    The conf/Application.xml configuration file will be used for every application, except if you use a specific Application.xml file for a particular application.
    If you want to have application specific configuration, then you should create a "conf/MobileCommTest/" folder where you can place your Application.xml file.
    Please take a look at the Live streaming configuration article (in step 2 the application specific configuration file is created)

    Zoran

Similar Threads

  1. Replies: 1
    Last Post: 09-25-2014, 08:50 PM
  2. can not play live stream recorded file in jwplayer
    By malarprathap in forum Video On Demand Streaming Discussion
    Replies: 4
    Last Post: 02-14-2013, 07:32 AM
  3. a problem about publishing a live stream with SDP file
    By z297470279z in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 10-09-2012, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •